Bug 1298996 - Weird errors accessing the disk under kernel 4.3.3 (PAE)
Weird errors accessing the disk under kernel 4.3.3 (PAE)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1302969 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 11:06 EST by Maurizio Paolini
Modified: 2016-01-29 08:11 EST (History)
8 users (show)

See Also:
Fixed In Version: kernel-4.3.3-303.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:23:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maurizio Paolini 2016-01-15 11:06:04 EST
Description of problem:

After updating to version 4.3.3-300 (PAE) weird errors like:
  ata2.00: exception Emase 0x0 Sact ...
started appearing, with occasional corruption of files in the filesystem

Version-Release number of selected component (if applicable):

kernel-PAE-core-4.3.3-300.fc23.i686

How reproducible:

The errors above appear in /var/log/messages soon after boot


Additional info:

This problem was addressed and fixed upstream:
   https://bugzilla.kernel.org/show_bug.cgi?id=109661
and seems specific to the PAE kernel, so probably it is enough to just update to the new kernel version.
Comment 1 Josh Boyer 2016-01-15 12:42:09 EST
Thanks for the pointer to the patch.  I've added it in Fedora git since upstream stable seems to be really behind.
Comment 2 Maurizio Paolini 2016-01-18 14:07:54 EST
I see that kernel-PAE-core-4.3.3-301.fc23.i686.rpm is in updates-testing.  Should I try it?  My current situation is that I must boot with an older kernel, otherwise (with 4.3.3-300) I am losing data!
Comment 3 Josh Boyer 2016-01-18 14:12:15 EST
No, that kernel does not contain the patch for this bug.  It will be in the next build and the updates system will leave a comment in this bug when it is present.
Comment 4 Fedora Update System 2016-01-19 07:54:12 EST
kernel-4.3.3-302.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-db9fedd7c4
Comment 5 Fedora Update System 2016-01-20 16:57:48 EST
kernel-4.3.3-303.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b59fd603be
Comment 6 Fedora Update System 2016-01-21 23:57:38 EST
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b59fd603be
Comment 7 Josh Boyer 2016-01-22 07:29:31 EST
*** Bug 1300911 has been marked as a duplicate of this bug. ***
Comment 8 Maurizio Paolini 2016-01-25 12:31:33 EST
I would like to urge the move of the kernel update from updates-testing to
updates.

The motivation is that most users of PAE kernel, version 4.3.3-300 (there might still be a fair amount of them) will probably experience strange errors even with occasional data corruption on their ATA drive without even knowing that the responsible is the kernel... The only way to fix their problem would be through a regular update!
Comment 9 Josh Boyer 2016-01-25 13:18:21 EST
It's being submitted today.
Comment 10 Maurizio Paolini 2016-01-26 11:38:20 EST
I am puzzled... The package disappeared from updates-testing, but it is still not
present in updates.  Is this ok?
Comment 11 Josh Boyer 2016-01-26 11:56:15 EST
(In reply to Maurizio Paolini from comment #10)
> I am puzzled... The package disappeared from updates-testing, but it is
> still not
> present in updates.  Is this ok?

Yes.  It's in the middle of being pushed to stable and the kernel that replaced it (4.3.4-300) also contains the fix.  Everything is fine.
Comment 12 Fedora Update System 2016-01-26 13:21:30 EST
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Josh Boyer 2016-01-29 08:11:12 EST
*** Bug 1302969 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.