Bug 1299027 - UI: Automate/Simulation screen throws an error
UI: Automate/Simulation screen throws an error
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Aziza Karol
: ZStream
Depends On: 1299010
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 12:47 EST by Chris Pelland
Modified: 2016-02-10 10:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1299010
Environment:
Last Closed: 2016-02-10 10:35:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-01-15 17:57:29 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6809c432a3e7b48bc8aa86933766c95b5afa9c2a

commit 6809c432a3e7b48bc8aa86933766c95b5afa9c2a
Merge: ca87970 e853721
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Jan 15 17:53:48 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Jan 15 17:53:48 2016 -0500

    Merge branch '55z_pr_6202' into '5.5.z'
    
    Added @right_cell_text for Automate Simulation screen
    
    URI.unescape was blowing up since @right_cell_text was nil. This issue was introduced with changes in https://github.com/ManageIQ/manageiq/pull/6140 for https://bugzilla.redhat.com/show_bug.cgi?id=1282606. Added code to set @right_cell_text and also added check to only URI.unescape if @right_cell_text is not nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299010
    https://bugzilla.redhat.com/show_bug.cgi?id=1299027
    (cherry picked from commit 3afcf8b)
    
    @dclarizi please review/merge, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6202
    
    See merge request !724

 app/controllers/application_controller/automate.rb | 1 +
 app/views/layouts/_content.html.haml               | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
Comment 3 CFME Bot 2016-01-15 17:57:38 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e8537212c5de87842d3dcc5a8185d6095cf392a3

commit e8537212c5de87842d3dcc5a8185d6095cf392a3
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Jan 15 12:45:53 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Jan 15 16:30:53 2016 -0500

    Added @right_cell_text for Automate Simulation screen
    
    URI.unescape was blowing up since @right_cell_text was nil. This issue was introduced with changes in https://github.com/ManageIQ/manageiq/pull/6140 for https://bugzilla.redhat.com/show_bug.cgi?id=1282606. Added code to set @right_cell_text and also added check to only URI.unescape if @right_cell_text is not nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1299010
    https://bugzilla.redhat.com/show_bug.cgi?id=1299027
    (cherry picked from commit 3afcf8b)

 app/controllers/application_controller/automate.rb | 1 +
 app/views/layouts/_content.html.haml               | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
Comment 5 Aziza Karol 2016-01-27 01:11:10 EST
No error in Automate/Simulation screen.

Verified :5.5.2.2.20160121120249_395c086
Comment 6 errata-xmlrpc 2016-02-10 10:35:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.