Bug 1302185 - [RFE] Allow attaching shared storage domains to a local DC
[RFE] Allow attaching shared storage domains to a local DC
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity unspecified with 3 votes (vote)
: ovirt-4.1.0-alpha
: 4.1.0.2
Assigned To: Maor
Lilach Zitnitski
: FutureFeature
: 1337555 (view as bug list)
Depends On:
Blocks: 1039606 1134318 1309212 1337555 1353134 1420575
  Show dependency treegraph
 
Reported: 2016-01-27 00:02 EST by Allon Mureinik
Modified: 2017-02-08 20:12 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Users can now change an initialized Data Center type to Shared or Local. The following updates will be available: 1. Shared to Local - Only for a Data Center that does not contain more than one host and more than one cluster, since a local Data Center does not support it. The Manager will validate and block this operation with the following messages: CLUSTER_CANNOT_ADD_MORE_THEN_ONE_HOST_TO_LOCAL_STORAGE VDS_CANNOT_ADD_MORE_THEN_ONE_HOST_TO_LOCAL_STORAGE 2. Local to Shared - Only for a Data Center that does not contain a local Storage Domain. The Manager will validate and block this operation with the following message: ERROR_CANNOT_CHANGE_STORAGE_POOL_TYPE_WITH_LOCAL. This update is useful for data domains that are used to move virtual machines or templates around.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:48:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
lzitnits: testing_plan_complete+
ylavi: planning_ack+
amureini: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 60169 master MERGED core: Update storage pool from local to shared and vice versa 2016-07-11 11:04 EDT
oVirt gerrit 60170 master MERGED core: Change shared/local validation on attach SD to DC. 2016-07-11 11:04 EDT
oVirt gerrit 60171 master MERGED webadmin: Present shared SD and local DCs on attach. 2016-07-11 11:04 EDT
oVirt gerrit 60172 master MERGED webadmin: New SD types should not be filtered for local DCs. 2016-07-11 11:04 EDT
oVirt gerrit 60194 master MERGED core: Allow detach of shared SD from local DC 2016-07-11 11:05 EDT
oVirt gerrit 60195 master MERGED core: Remove local DC for shared SD 2016-07-11 11:05 EDT
oVirt gerrit 60235 master MERGED webadmin:Enable storage type at data center popup. 2016-07-11 11:04 EDT
oVirt gerrit 60296 master MERGED core: Change attach error message to be suitable for local. 2016-07-11 11:06 EDT
oVirt gerrit 60506 master MERGED core: Add validation for update shared DC to local DC. 2016-07-11 11:05 EDT

  None (edit)
Description Allon Mureinik 2016-01-27 00:02:12 EST
Description of problem:
With the ability to attach and detach a data domain (introduced in 3.5), data domains become a better option for moving VMs/Templates around than an export domain. 
In order to gain this ability in local DCs, it should be possible to attach a storage domain of a shared type to that DC.

This RFE essentially re-defines a local DC as A DC that's allowed to have just one host, bringing it closer to the general DC concept.

Important flows to check:
1. Attach/Detach domains
2. Master creation/migration/reconstruction
3. Moving between a local and a shared domain
4. Live Storage Migration between a local and a shared domain
Comment 1 Allon Mureinik 2016-06-30 06:42:22 EDT
*** Bug 1337555 has been marked as a duplicate of this bug. ***
Comment 2 Yaniv Lavi 2016-07-13 10:56:14 EDT
Is this the same as BZ #1109597?
Comment 3 Yaniv Lavi 2016-07-13 10:58:31 EDT
Also BZ #1134318?
Comment 4 Maor 2016-07-13 12:00:12 EDT
Regarding BZ1134318, we are not there yet.
A local DC can have only one Host, this RFE was that the engine can now also maintain shared SDs as well.

Regarding BZ1109597, based on the bug comments it looks like this bug should address the issue of supporting multiple types of storage domains in a DC, but 
keep in mind, there is no support for local DC with multiple hosts.
Comment 5 Sandro Bonazzola 2016-12-12 08:55:40 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 6 Yaniv Lavi 2016-12-14 11:21:20 EST
This bug had requires_doc_text flag, yet no documentation text was provided. Please add the documentation text and only then set this flag.

Note You need to log in before you can comment on or make changes to this bug.