Bug 1302271 - Provisioning request approval - incorrect flash message text
Provisioning request approval - incorrect flash message text
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity low
: GA
: 5.6.0
Assigned To: Roman Blanco
Jan Krocil
flash_msg:service
: ZStream
: 1305733 1313521 (view as bug list)
Depends On:
Blocks: 1305954
  Show dependency treegraph
 
Reported: 2016-01-27 05:46 EST by Jan Krocil
Modified: 2016-06-29 11:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1305954 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:33:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Krocil 2016-01-27 05:46:35 EST
Description of problem:
When a request for configured system reprovision/reconfiguration is approved, an incorrect flash message is displayed stating that the request has been denied.
The request is approved and works fine but the test of the flash message is wrong.

Version-Release number of selected component (if applicable):
5.5.2.2

How reproducible:
Always

Steps to Reproduce:
1. Add a configuration manager
2. Reprovision a configured system
3. Apporove the request
4. Check the flash message

Actual results:
'Request "Red Hat Satellite install on [<hostname>]" was denied'

Expected results:
'Request "Red Hat Satellite install on [<hostname>]" was approved'

Additional info:
Comment 2 Shveta 2016-01-27 14:42:55 EST
Assigning to add test case
Comment 4 CFME Bot 2016-02-01 12:40:58 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/0b1fbf4e62fffc643bc7b2aed5ce954a53dd8136

commit 0b1fbf4e62fffc643bc7b2aed5ce954a53dd8136
Author:     Roman Blanco <rblanco@redhat.com>
AuthorDate: Mon Feb 1 14:37:31 2016 +0100
Commit:     Roman Blanco <rblanco@redhat.com>
CommitDate: Mon Feb 1 14:37:31 2016 +0100

    Corrected condition for request approval flash message
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302271

 app/controllers/miq_request_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 Dan Clarizio 2016-02-09 09:45:42 EST
*** Bug 1305733 has been marked as a duplicate of this bug. ***
Comment 8 CFME Bot 2016-02-15 10:38:23 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 9 CFME Bot 2016-02-29 18:58:09 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=077716129c9d37f4fe4c20846c1252d1d216b983

commit 077716129c9d37f4fe4c20846c1252d1d216b983
Author:     Roman Blanco <rblanco@redhat.com>
AuthorDate: Mon Feb 1 14:37:31 2016 +0100
Commit:     Roman Blanco <rblanco@redhat.com>
CommitDate: Mon Feb 29 17:13:53 2016 +0100

    Corrected condition for request approval flash message
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302271

 app/controllers/miq_request_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 10 CFME Bot 2016-02-29 18:58:23 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f6db2d6feac988d8b833f7b19ceb544cf2f89f2e

commit f6db2d6feac988d8b833f7b19ceb544cf2f89f2e
Merge: adddc6a 0777161
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 29 18:40:24 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Feb 29 18:40:24 2016 -0500

    Merge branch 'bz1305954' into '5.5.z'
    
    Corrected condition for request approval flash message
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1302271
    
    clean cherry-pick
    
    See merge request !808

 app/controllers/miq_request_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 11 Harpreet Kataria 2016-03-01 14:04:12 EST
*** Bug 1313521 has been marked as a duplicate of this bug. ***
Comment 12 Jan Krocil 2016-04-19 06:53:22 EDT
Verified fixed in 5.6-beta2 - 5.6.0.1-beta2.20160413141124_e25ac0e.
Comment 14 errata-xmlrpc 2016-06-29 11:33:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.