Bug 1303419 - launch-fusor-installer fails with "Could not set 'present' on ensure: 422 Unprocessable Entity at 12:/usr/share/katello-installer/modules/foreman_proxy/manifests/register.pp"
launch-fusor-installer fails with "Could not set 'present' on ensure: 422 Unp...
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Settings (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Thom Carlin
:
Depends On:
Blocks: rhci-common-installer 1215225 1295743
  Show dependency treegraph
 
Reported: 2016-01-31 10:50 EST by Thom Carlin
Modified: 2016-06-21 09:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-20 12:05:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 7579 None None None 2016-01-31 13:48 EST
Foreman Issue Tracker 8657 None None None 2016-01-31 13:48 EST

  None (edit)
Description Thom Carlin 2016-01-31 10:50:27 EST
Description of problem:

launch-fusor-installer fails on bare-metal system that has worked many times before

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20160128.t.1

How reproducible:

Unsure

Steps to Reproduce:
1. Install using RHCS-I ISO
2. Log in to run launch-fusor-installer
3.

Actual results:

Could not set 'present' on ensure: 422 Unprocessable Entity at 12:/usr/share/katello-installer/modules/foreman_proxy/manifests/register.pp

Expected results:

Successful install

Additional info:

Found https://bugzilla.redhat.com/show_bug.cgi?id=1143065, https://access.redhat.com/solutions/1230493, http://projects.theforeman.org/issues/8657, http://projects.theforeman.org/issues/7983
but logfile/diagnostics do not appear to be a perfect match
Comment 2 Thom Carlin 2016-01-31 13:47:52 EST
2016-01-31 13:24:03 [I] Authorized user foreman_api_admin(API Admin)
2016-01-31 13:24:03 [E] Unprocessable entity SmartProxy (id: new):
  Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([RestClient::RequestTimeout]: Request Timeout) for proxy https://<hostname>:9090/features
  Please check the proxy is configured and running on the host.

2016-01-31 13:24:03 [I]   Rendered api/v2/errors/unprocessable_entity.json.rabl within api/v2/layouts/error_layout (0.5ms)
2016-01-31 13:24:03 [I] Completed 422 Unprocessable Entity in 23ms (Views: 1.1ms | ActiveRecord: 2.1ms)

Workaround:
foreman-rake config -- -k proxy_request_timeout -v 99
Comment 3 Thom Carlin 2016-01-31 14:00:09 EST
Workaround is inconsistently effective
Comment 4 Thom Carlin 2016-01-31 15:28:04 EST
Redeploying from ISO on same hardware with same parameters was successful.  Uploading "good" foreman-debug for comparison purposes.
Comment 6 Bryan Kearney 2016-05-02 13:43:58 EDT
Upstream bug component is Settings
Comment 8 Thom Carlin 2016-06-20 10:14:56 EDT
Message does not appear in QCI 1.2 -- Verified as of QCI-1.2-RHEL-7-20160613.t.0.
Comment 9 Bryan Kearney 2016-06-20 12:05:53 EDT
Closing this out as NEXTRELEASE. It will be delivered with 6.2.
Comment 10 Thom Carlin 2016-06-21 09:48:33 EDT
Addendum: Since issue is not consistently reproducible, Verified by ensuring upstream code is present in Sat 6.2

Note You need to log in before you can comment on or make changes to this bug.