Bug 1303501 - access-control : spurious error log message on every setxattr call
Summary: access-control : spurious error log message on every setxattr call
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: access-control
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Jiffin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1304350 1308800
TreeView+ depends on / blocked
 
Reported: 2016-02-01 05:30 UTC by Jiffin
Modified: 2016-06-16 13:56 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1304350 1308800 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:56:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jiffin 2016-02-01 05:30:09 UTC
Description of problem:

Spurious log message is filled in gluster logs on every setxattr call. This is due to a check is missed before calling the handling_other_acl_related_xattr() in
posix_acl_setxattr_cbk()

Version-Release number of selected component (if applicable):
mainline


Additional info 

log message :
[2016-01-31 17:38:48.027792] I [dict.c:473:dict_get] (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so(posix_acl_setxattr_cbk+0x26) [0x7f2334c5c166] -->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so(handling_other_acl_related_xattr+0xb0) [0x7f2334c5c0f0] -->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(dict_get+0x93) [0x7f233c04b0c3] ) 0-dict: !this || key=system.posix_acl_default [Invalid argument]

Comment 1 Vijay Bellur 2016-02-01 05:45:24 UTC
REVIEW: http://review.gluster.org/13325 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 2 Vijay Bellur 2016-02-08 06:48:52 UTC
REVIEW: http://review.gluster.org/13325 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 3 Vijay Bellur 2016-02-09 14:33:43 UTC
COMMIT: http://review.gluster.org/13325 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit b72172f4516ff5627f15168213a54b171463803f
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Feb 1 11:02:37 2016 +0530

    access-control : remove spurious error message from the posix_setxattr_cbk
    
    A check for dictionary is required before calling handling_other_acl_related_xattr()
    in posix_setxattr_cbk(). Otherwise following message will be poped up on every settxattr
    call.
    
    [2016-01-31 17:38:48.027792] I [dict.c:473:dict_get]
     (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so
    (posix_acl_setxattr_cbk+0x26) [0x7f2334c5c166] -->
    /usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so
    (handling_other_acl_related_xattr+0xb0) [0x7f2334c5c0f0]
    -->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(dict_get+0x93)
    [0x7f233c04b0c3] ) 0-dict: !this ||
    key=system.posix_acl_default [Invalid argument]
    
    Change-Id: I93f7e0f764c94dce38bdde95a68341f69a52122d
    BUG: 1303501
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13325
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 4 Niels de Vos 2016-06-16 13:56:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.