Bug 1308800 - access-control : spurious error log message on every setxattr call
access-control : spurious error log message on every setxattr call
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: access-control (Show other bugs)
3.7.7
All All
medium Severity medium
: ---
: ---
Assigned To: Jiffin
: EasyFix, Triaged
Depends On: 1303501
Blocks: 1304350 glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-16 01:53 EST by Jiffin
Modified: 2016-04-19 03:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1303501
Environment:
Last Closed: 2016-04-19 03:24:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2016-02-16 01:53:25 EST
+++ This bug was initially created as a clone of Bug #1303501 +++

Description of problem:

Spurious log message is filled in gluster logs on every setxattr call. This is due to a check is missed before calling the handling_other_acl_related_xattr() in
posix_acl_setxattr_cbk()

Version-Release number of selected component (if applicable):
mainline


Additional info 

log message :
[2016-01-31 17:38:48.027792] I [dict.c:473:dict_get] (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so(posix_acl_setxattr_cbk+0x26) [0x7f2334c5c166] -->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so(handling_other_acl_related_xattr+0xb0) [0x7f2334c5c0f0] -->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(dict_get+0x93) [0x7f233c04b0c3] ) 0-dict: !this || key=system.posix_acl_default [Invalid argument]

--- Additional comment from Vijay Bellur on 2016-02-01 00:45:24 EST ---

REVIEW: http://review.gluster.org/13325 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-08 01:48:52 EST ---

REVIEW: http://review.gluster.org/13325 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-09 09:33:43 EST ---

COMMIT: http://review.gluster.org/13325 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit b72172f4516ff5627f15168213a54b171463803f
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Feb 1 11:02:37 2016 +0530

    access-control : remove spurious error message from the posix_setxattr_cbk
    
    A check for dictionary is required before calling handling_other_acl_related_xattr()
    in posix_setxattr_cbk(). Otherwise following message will be poped up on every settxattr
    call.
    
    [2016-01-31 17:38:48.027792] I [dict.c:473:dict_get]
     (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so
    (posix_acl_setxattr_cbk+0x26) [0x7f2334c5c166] -->
    /usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so
    (handling_other_acl_related_xattr+0xb0) [0x7f2334c5c0f0]
    -->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(dict_get+0x93)
    [0x7f233c04b0c3] ) 0-dict: !this ||
    key=system.posix_acl_default [Invalid argument]
    
    Change-Id: I93f7e0f764c94dce38bdde95a68341f69a52122d
    BUG: 1303501
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13325
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 1 Vijay Bellur 2016-02-16 01:56:37 EST
REVIEW: http://review.gluster.org/13452 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#1) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-02-16 05:27:48 EST
REVIEW: http://review.gluster.org/13452 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#2) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)
Comment 3 Vijay Bellur 2016-02-18 09:02:24 EST
COMMIT: http://review.gluster.org/13452 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 2cbbff904fee3ecb315f2c3229380dff3d483fde
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Feb 1 11:02:37 2016 +0530

    access-control : remove spurious error message from the posix_setxattr_cbk
    
    A check for dictionary is required before calling handling_other_acl_related_xattr()
    in posix_setxattr_cbk(). Otherwise following message will be poped up on every settxattr
    call.
    
    [2016-01-31 17:38:48.027792] I [dict.c:473:dict_get]
     (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so
    (posix_acl_setxattr_cbk+0x26) [0x7f2334c5c166] -->
    /usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so
    (handling_other_acl_related_xattr+0xb0) [0x7f2334c5c0f0]
    -->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(dict_get+0x93)
    [0x7f233c04b0c3] ) 0-dict: !this ||
    key=system.posix_acl_default [Invalid argument]
    
    Upstream reference :
    >Change-Id: I93f7e0f764c94dce38bdde95a68341f69a52122d
    >BUG: 1303501
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/13325
    >Smoke: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    >(cherry picked from commit b72172f4516ff5627f15168213a54b171463803f)
    
    BUG: 1308800
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Change-Id: Ide2aea41c01c00bf28294fd3ea4f1d538f54b26f
    Reviewed-on: http://review.gluster.org/13452
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 4 Kaushal 2016-04-19 03:24:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.