Bug 1304350 - access-control : spurious error log message on every setxattr call [NEEDINFO]
access-control : spurious error log message on every setxattr call
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
3.1
All All
medium Severity medium
: ---
: ---
Assigned To: Jiffin
Rochelle
: EasyFix, Triaged, ZStream
Depends On: 1303501 1308800
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 06:57 EST by Rahul Hinduja
Modified: 2018-04-17 23:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1303501
Environment:
Last Closed: 2018-04-16 11:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sanandpa: needinfo? (rallan)


Attachments (Terms of Use)

  None (edit)
Description Rahul Hinduja 2016-02-03 06:57:08 EST
+++ This bug was initially created as a clone of Bug #1303501 +++

Description of problem:

Spurious log message is filled in gluster logs on every setxattr call. This is due to a check is missed before calling the handling_other_acl_related_xattr() in
posix_acl_setxattr_cbk()

Version-Release number of selected component (if applicable):
mainline


Additional info 

log message :
[2016-01-31 17:38:48.027792] I [dict.c:473:dict_get] (-->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so(posix_acl_setxattr_cbk+0x26) [0x7f2334c5c166] -->/usr/lib/x86_64-linux-gnu/glusterfs/3.7.6/xlator/system/posix-acl.so(handling_other_acl_related_xattr+0xb0) [0x7f2334c5c0f0] -->/usr/lib/x86_64-linux-gnu/libglusterfs.so.0(dict_get+0x93) [0x7f233c04b0c3] ) 0-dict: !this || key=system.posix_acl_default [Invalid argument]

--- Additional comment from Vijay Bellur on 2016-02-01 00:45:24 EST ---

REVIEW: http://review.gluster.org/13325 (access-control : remove spurious error message from the posix_setxattr_cbk) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Jiffin 2018-01-11 04:49:14 EST
IMO this fix is already part of upstream 3.8, so should be available from 3.2 onwards. So can we please close this bug as "CURRENT RELEASE"

Note You need to log in before you can comment on or make changes to this bug.