Bug 1303591 - AFR+SNAPSHOT: File with hard link have different inode number in USS
AFR+SNAPSHOT: File with hard link have different inode number in USS
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.1
x86_64 Linux
unspecified Severity urgent
: ---
: RHGS 3.1.3
Assigned To: Manikandan
Anil Shah
USS
: Patch, Triaged, ZStream
Depends On: 1170365
Blocks: 1153907 1171703 1299184 1316099
  Show dependency treegraph
 
Reported: 2016-02-01 06:47 EST by Vijaikumar Mallikarjuna
Modified: 2016-09-17 09:04 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1170365
Environment:
Last Closed: 2016-06-23 01:06:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Vijaikumar Mallikarjuna 2016-02-01 06:49:19 EST
Patch submitted upstream: http://review.gluster.org/#/c/9255/
Comment 4 Avra Sengupta 2016-03-10 04:45:04 EST
Master URL: http://review.gluster.org/#/c/9255/ (IN REVIEW)
Release 3.7 URL: http://review.gluster.org/#/c/13656/ (IN REVIEW)
Comment 7 Anil Shah 2016-03-30 03:14:46 EDT
Still seeing inode number for hard link file is different in USS on build glusterfs-3.7.9-1.el7rhgs.x86_64.

Output from USS:
============================================
[root@dhcp46-47 snap1]# ls -ltrhi myfile 
13005932563110049509 -rw-r--r--. 2 root root 13 Mar 29 23:52 myfile
[root@dhcp46-47 snap1]# ls -ltrhi newfile 
10093952695401965882 -rw-r--r--. 2 root root 13 Mar 29 23:52 newfile



Output from snapshot:
============================================
[root@dhcp46-47 nfs]# ls -ltrhi newfile 
13771270023539088487 -rw-r--r--. 2 root root 13 Mar 29 23:45 newfile
[root@dhcp46-47 nfs]# ls -ltrhi myfile 
13771270023539088487 -rw-r--r--. 2 root root 13 Mar 29 23:45 myfile

Moving back to assigned state.
Comment 8 Vijaikumar Mallikarjuna 2016-03-30 08:56:17 EDT
Hi Anil,

Your test-case is wrong:

Here is the test-case
1) create a file1
2) create a hard-link file2
3) create snapshot snap1
4) create snapshot snap2

Inside snap1
inode-number of file1 = inode-numer of file1

Please don't compare with inode number outside snap1

Thanks,
Vijay
Comment 9 Avra Sengupta 2016-04-05 04:30:10 EDT
Failed QA because the build got spawned right before this patch got merged into the 3.1.3 branch. Moving it to POST.
Comment 10 Vijaikumar Mallikarjuna 2016-04-06 23:27:56 EDT
Patch "https://code.engineering.redhat.com/gerrit/#/c/70563/" is merged
Comment 11 Anil Shah 2016-04-25 04:19:45 EDT
Hard link file have same inode number as source file.
Bug verified on build glusterfs-3.7.9-2.el7rhgs.x86_64

Output from client
[root@dhcp46-47 fuse]# ls -ai  myfile 
11820165462172882239 myfile
[root@dhcp46-47 fuse]# ls -ai  newfile 
11820165462172882239 newfile


Output from USS
[root@dhcp46-47 snap1]# ls -i myfile 
1667499072259270622 myfile
[root@dhcp46-47 snap1]# ls -i newfile 
1667499072259270622 newfile
Comment 12 Anil Shah 2016-04-25 04:20:26 EDT
Hard link file have same inode number as source file.
Bug verified on build glusterfs-3.7.9-2.el7rhgs.x86_64

Output from client
[root@dhcp46-47 fuse]# ls -ai  myfile 
11820165462172882239 myfile
[root@dhcp46-47 fuse]# ls -ai  newfile 
11820165462172882239 newfile


Output from USS
[root@dhcp46-47 snap1]# ls -i myfile 
1667499072259270622 myfile
[root@dhcp46-47 snap1]# ls -i newfile 
1667499072259270622 newfile
Comment 16 errata-xmlrpc 2016-06-23 01:06:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.