Bug 1316099 - AFR+SNAPSHOT: File with hard link have different inode number in USS
AFR+SNAPSHOT: File with hard link have different inode number in USS
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.9
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
USS
:
Depends On: 1170365 1171703 1303591
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 07:16 EST by Vijaikumar Mallikarjuna
Modified: 2016-04-19 02:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1171703
Environment:
Last Closed: 2016-04-19 02:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-09 07:16:55 EST
REVIEW: http://review.gluster.org/13656 (uss/gluster: generate gfid for snapshot files from snapname and gfid) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-03-23 07:04:09 EDT
COMMIT: http://review.gluster.org/13656 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit ed4feadc8c60fce1d8d99e0732351b92230d6321
Author: vmallika <vmallika@redhat.com>
Date:   Wed Feb 10 06:39:22 2016 +0530

    uss/gluster: generate gfid for snapshot files from snapname and gfid
    
    This is a backport of http://review.gluster.org/#/c/9255/
    
    If 'a' and 'b' are hardlinks, we need to generate a virtual
    gfid for these files so that the inode number for 'a' and 'b'
    are same.
    
    Generate gfid as below:
    gfid_of_a = MD5(snapname + back_end_gfid(a))
    if '/dir1/a' and '/dir2/b' are hardlinks, then inode number should be
    same for
    all below files:
    /mnt/.snaps/snap1/dir1/a
    /mnt/.snaps/snap1/dir2/b
    /mnt/dir1/.snaps/snap1/a
    /mnt/dir2/.snaps/snap1/b
    
    > Change-Id: Ifda793455610e554f3f1e4cbb90d44c02cda4b0f
    > BUG: 1171703
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I917b2fe2915d88f69700bc8c3283e9c613e13bb8
    BUG: 1316099
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13656
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Kaushal 2016-04-19 02:59:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.