Bug 1304297 - [abrt] meld: meldapp.py:277:parse_args:UnboundLocalError: local variable 'args' referenced before assignment
[abrt] meld: meldapp.py:277:parse_args:UnboundLocalError: local variable 'arg...
Status: CLOSED DUPLICATE of bug 1216120
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:18b0ac0b46112957112e2fab0c9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 04:40 EST by rh
Modified: 2016-05-04 04:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-04 04:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.54 KB, text/plain)
2016-02-03 04:40 EST, rh
no flags Details
File: environ (3.47 KB, application/octet-stream)
2016-02-03 04:40 EST, rh
no flags Details

  None (edit)
Description rh 2016-02-03 04:40:29 EST
Description of problem:
I tried to merge files by calling "git mergetool" (my merge tool is set to meld).

Version-Release number of selected component:
meld-3.14.0-2.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/meld --help
executable:     /usr/bin/meld
kernel:         4.3.3-303.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
meldapp.py:277:parse_args:UnboundLocalError: local variable 'args' referenced before assignment

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 72, in do_command_line
    tab = self.parse_args(command_line)
  File "/usr/lib/python2.7/site-packages/meld/meldapp.py", line 277, in parse_args
    if len(args) > 3:
UnboundLocalError: local variable 'args' referenced before assignment

Local variables in innermost frame:
usages: [('', u'\u4f55\u3082\u958b\u304b\u305a\u306b Meld \u3092\u8d77\u52d5\u3059\u308b'), (u'<FILE|folder>', u'\u30d0\u30fc\u30b8\u30e7\u30f3\u7ba1\u7406\u306e\u6bd4\u8f03\u30e2\u30fc\u30c9\u3067\u8d77\u52d5\u3059\u308b'), (u'<FILE> <FILE> [<FILE>]', u'2\u306a\u3044\u30573\u500b\u306e\u30d5\u30a1\u30a4\u30eb\u3092\u6bd4\u8f03\u3059\u308b\u30e2\u30fc\u30c9\u3067\u8d77\u52d5\u3059\u308b'), (u'<folder> <folder> [<folder>]', u'Start a 2- or 3-way folder comparison')]
self: <MeldApp object at 0x7fc1ec065d70 (meld+meldapp+MeldApp at 0x55ff0d4c0210)>
parser: <meld.meldapp.GLibFriendlyOptionParser instance at 0x7fc1dd78c368>
command_line: <ApplicationCommandLine object at 0x7fc1dd782e10 (GApplicationCommandLine at 0x55ff0d92cba0)>
s: (u'<folder> <folder> [<folder>]', u'Start a 2- or 3-way folder comparison')
rawargs: ['--help']
cleanup: <function cleanup at 0x7fc1dd77a668>
u: (u'<folder> <folder> [<folder>]', u'Start a 2- or 3-way folder comparison')
usage: u'\n  %prog                              \u4f55\u3082\u958b\u304b\u305a\u306b Meld \u3092\u8d77\u52d5\u3059\u308b\n  %prog <FILE|folder>                \u30d0\u30fc\u30b8\u30e7\u30f3\u7ba1\u7406\u306e\u6bd4\u8f03\u30e2\u30fc\u30c9\u3067\u8d77\u52d5\u3059\u308b\n  %prog <FILE> <FILE> [<FILE>]       2\u306a\u3044\u30573\u500b\u306e\u30d5\u30a1\u30a4\u30eb\u3092\u6bd4\u8f03\u3059\u308b\u30e2\u30fc\u30c9\u3067\u8d77\u52d5\u3059\u308b\n  %prog <folder> <folder> [<folder>] Start a 2- or 3-way folder comparison'
usage_lines: [u'  %prog                              \u4f55\u3082\u958b\u304b\u305a\u306b Meld \u3092\u8d77\u52d5\u3059\u308b', u'  %prog <FILE|folder>                \u30d0\u30fc\u30b8\u30e7\u30f3\u7ba1\u7406\u306e\u6bd4\u8f03\u30e2\u30fc\u30c9\u3067\u8d77\u52d5\u3059\u308b', u'  %prog <FILE> <FILE> [<FILE>]       2\u306a\u3044\u30573\u500b\u306e\u30d5\u30a1\u30a4\u30eb\u3092\u6bd4\u8f03\u3059\u308b\u30e2\u30fc\u30c9\u3067\u8d77\u52d5\u3059\u308b', u'  %prog <folder> <folder> [<folder>] Start a 2- or 3-way folder comparison']
GLibFriendlyOptionParser: <class meld.meldapp.GLibFriendlyOptionParser at 0x7fc1dd768e20>
pad_args_fmt: '%-28s %s'

Potential duplicate: bug 1252882
Comment 1 rh 2016-02-03 04:40:33 EST
Created attachment 1120704 [details]
File: backtrace
Comment 2 rh 2016-02-03 04:40:36 EST
Created attachment 1120705 [details]
File: environ
Comment 3 Pavel Alexeev 2016-05-04 04:31:28 EDT

*** This bug has been marked as a duplicate of bug 1216120 ***

Note You need to log in before you can comment on or make changes to this bug.