Bug 1304617 - [RFE] Custom oVirt Dashboard for Cockpit
[RFE] Custom oVirt Dashboard for Cockpit
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
high Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0
Assigned To: Ryan Barry
Lei Wang
: FutureFeature
: 1318379 (view as bug list)
Depends On: 1318414 1318415 1318416 1318417 1329104
Blocks: ovirt-node-ng 1318379 1352435
  Show dependency treegraph
 
Reported: 2016-02-04 03:09 EST by Fabian Deutsch
Modified: 2016-07-05 03:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: ovirt-node-ng-installer-ovirt-4.0-2016051906.iso
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1318379 (view as bug list)
Environment:
Last Closed: 2016-07-05 03:45:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
ycui: testing_plan_complete?
mgoldboi: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2016-02-04 03:09:38 EST
Description of problem:
To group oVirt specific bits, Node should get it's own dashboard in Cockpit.

There is already one for kubernetes (https://github.com/cockpit-project/cockpit/blob/master/pkg/kubernetes/dashboard.js) which can be used for reference.

The dashboard should at least be the starting point for bug 1298160
Comment 3 Red Hat Bugzilla Rules Engine 2016-02-08 05:12:52 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Ryan Barry 2016-03-16 13:29:23 EDT
Contents of the dashboard (only passive):

Statistics
List VMs
Actual accumulated VM usage charts (cpu/mem/disk/net)
View SSH Host key
Network IP address information
HE Status
Comment 5 Yaniv Kaul 2016-03-16 13:59:27 EDT
(In reply to Ryan Barry from comment #4)
> Contents of the dashboard (only passive):
> 
> Statistics
> List VMs
> Actual accumulated VM usage charts (cpu/mem/disk/net)
> View SSH Host key
> Network IP address information
> HE Status

Connected storage domains?
Package versions?
Comment 6 Ryan Barry 2016-03-16 14:05:05 EDT
(In reply to Yaniv Kaul from comment #5)
> (In reply to Ryan Barry from comment #4)
> > Contents of the dashboard (only passive):
> > 
> > Statistics
> > List VMs
> > Actual accumulated VM usage charts (cpu/mem/disk/net)
> > View SSH Host key
> > Network IP address information
> > HE Status
> 
> Connected storage domains?
> Package versions?

Both of these are options. I worry that connected storage domains provides too much overlap with engine functionality (at least to start with), but it's definitely something we can look at adding.
Comment 7 Yaniv Kaul 2016-03-16 14:09:16 EDT
(In reply to Ryan Barry from comment #6)
> (In reply to Yaniv Kaul from comment #5)
> > (In reply to Ryan Barry from comment #4)
> > > Contents of the dashboard (only passive):
> > > 
> > > Statistics
> > > List VMs
> > > Actual accumulated VM usage charts (cpu/mem/disk/net)
> > > View SSH Host key
> > > Network IP address information
> > > HE Status
> > 
> > Connected storage domains?
> > Package versions?
> 
> Both of these are options. I worry that connected storage domains provides
> too much overlap with engine functionality (at least to start with), but
> it's definitely something we can look at adding.

Multipathing status is a feature requested on engine (and isn't there) and is probably quite easy to do in Cockpit, btw.
Comment 8 Ryan Barry 2016-03-16 14:16:25 EDT
(In reply to Yaniv Kaul from comment #7)
> (In reply to Ryan Barry from comment #6)
> > (In reply to Yaniv Kaul from comment #5)
> > > (In reply to Ryan Barry from comment #4)
> > > > Contents of the dashboard (only passive):
> > > > 
> > > > Statistics
> > > > List VMs
> > > > Actual accumulated VM usage charts (cpu/mem/disk/net)
> > > > View SSH Host key
> > > > Network IP address information
> > > > HE Status
> > > 
> > > Connected storage domains?
> > > Package versions?
> > 
> > Both of these are options. I worry that connected storage domains provides
> > too much overlap with engine functionality (at least to start with), but
> > it's definitely something we can look at adding.
> 
> Multipathing status is a feature requested on engine (and isn't there) and
> is probably quite easy to do in Cockpit, btw.

I haven't checked on the status in a couple of weeks, but there's ongoing work with storaged and cockpit which may end up implementing this. I'll investigate.
Comment 9 Michal Skrivanek 2016-03-17 01:49:31 EDT
(In reply to Ryan Barry from comment #4)
> Contents of the dashboard (only passive):

> List VMs
> Actual accumulated VM usage charts (cpu/mem/disk/net)

this is an overlap as well. Not sure if worth investing in downstream in the first iteration. The calls to retrieve that might be too expensive, and we will have the same info in the "normal" 4.0 UI dashboard. I would propose to leave it open for now
Comment 10 Yaniv Kaul 2016-03-17 03:41:00 EDT
(In reply to Michal Skrivanek from comment #9)
> (In reply to Ryan Barry from comment #4)
> > Contents of the dashboard (only passive):
> 
> > List VMs
> > Actual accumulated VM usage charts (cpu/mem/disk/net)
> 
> this is an overlap as well. Not sure if worth investing in downstream in the
> first iteration. The calls to retrieve that might be too expensive, and we
> will have the same info in the "normal" 4.0 UI dashboard. I would propose to
> leave it open for now

True, unless we can pick it from vdsm-collect daemon I'd like to see introduced in the near future (splitting the metrics collection from VDSM and sending it to an independent metrics collection).
Comment 11 Ryan Barry 2016-03-17 11:00:49 EDT
(In reply to Michal Skrivanek from comment #9)
> (In reply to Ryan Barry from comment #4)
> > Contents of the dashboard (only passive):
> 
> > List VMs
> > Actual accumulated VM usage charts (cpu/mem/disk/net)
> 
> this is an overlap as well. Not sure if worth investing in downstream in the
> first iteration. The calls to retrieve that might be too expensive, and we
> will have the same info in the "normal" 4.0 UI dashboard. I would propose to
> leave it open for now

We also have the option of pulling this from libvirt just for a node-only summary (the current TUI shows how many VMs are running on the system as well), if vdsm is too expensive, though vdsm is obviously preferred.
Comment 12 Yaniv Kaul 2016-03-17 11:05:02 EDT
[pushed it out to 4.1 - I'd be happy to see this in 4.0 / 4.0.z, but I want it off the radar for 4.0 GA. I do expect work on it during 4.0 timeframe).
Comment 13 Fabian Deutsch 2016-03-17 11:29:16 EDT
Yaniv, this is actually part the Cockpit dashboard of Node for 4.0 and this is scheduled for 4.0 GA.
Comment 14 Sandro Bonazzola 2016-05-02 05:53:26 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 15 Fabian Deutsch 2016-05-19 07:14:33 EDT
*** Bug 1318379 has been marked as a duplicate of this bug. ***
Comment 16 wanghui 2016-06-02 01:07:21 EDT
Test version:
rhev-hypervisor7-ng-4.0-20160527.0
cockpit-ovirt-dashboard-0.10.1-0.0.1.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7-ng-4.0-20160527.0
2. Enter cockpit
3. Check the oVirt page

Test result:
1. In oVirt page, it now has the follow items.
   - Dashboard
     | - VirtualMachines' status
     | - View Networking information
     | - View System Logs
     | - View Storage
     | - Show SSH Host Key
   - Hosted Engine setup
   - Virtual Machines page

Ryan,

Could you please help to review the above test result. Is those items enough for cockpit page now? Or we still need to add more items in oVirt page.

Thanks!
Comment 17 Ryan Barry 2016-06-02 07:53:52 EDT
There will be one more page coming in the next couple of days (patch landing upstream today) --

"Hosted Engine Status"

Now that the necessary patches to ovirt-hosted-engine-setup have merged and are part of builds.

However, this page is simply presentation, so verification should be very easy.
Comment 18 wanghui 2016-06-08 02:22:33 EDT
"Hosted Engine Status" page is added in rhev-hypervisor7-ng-4.0-20160607.1.x86_64(cockpit-ovirt-dashboard-0.10.3-0.0.1.el7ev.noarch) now. So this issue can be verified. All the detail issues will be tracked by specific bugs.
Comment 20 Sandro Bonazzola 2016-07-05 03:45:49 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.