Bug 1304684 - [quota]: Incorrect disk usage shown on a tiered volume
[quota]: Incorrect disk usage shown on a tiered volume
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: RHGS 3.1.2
Assigned To: Vijaikumar Mallikarjuna
krishnaram Karthick
: ZStream
Depends On:
Blocks: 1304970 1305029
  Show dependency treegraph
 
Reported: 2016-02-04 05:57 EST by krishnaram Karthick
Modified: 2016-09-17 11:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304970 (view as bug list)
Environment:
Last Closed: 2016-03-01 01:09:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnaram Karthick 2016-02-04 05:57:58 EST
Description of problem:
When quota is enabled on a tiered volume and limit usage on root directory is set to a high value, data usage usage shown an inflated value. A value which is more than the capacity of actual volume size.

Actual value:
Filesystem             Size  Used Avail Use% Mounted on

10.70.37.120:/krk-vol  1.9T  627G  1.3T  34% /mnt/krkvol

value shown on client with quota enabled,
Filesystem             Size  Used Avail Use% Mounted on
10.70.37.120:/krk-vol  100P  9.5T  100P   1% /mnt/krkvol


Version-Release number of selected component (if applicable):
glusterfs-server-3.7.5-18.el7rhgs.x86_64

How reproducible:
Yet to be determined

Steps to Reproduce:
1. Create a volume, enable quota and set limit usage to root directory
2. Attach tier and have files promoted, new files written to hot tier
3. create multiple sub-directories and set limit usage
4. Have data written to these sub-directories
5. Disable quota
6. Enable quota
7. Repeat steps 3 & 4
8. Detach tier and wait for it to complete

Actual results:
disk usage shows incorrect value

Expected results:
Actual disk usage should be shown

Additional info:
Comment 3 Manikandan 2016-02-05 05:49:54 EST
Patch submitted upstream: http://review.gluster.org/13363

Patch submitted downstream:
https://code.engineering.redhat.com/gerrit/#/c/67161/
Comment 5 Manikandan 2016-02-05 06:37:08 EST
Patch posted 3.7 -> http://review.gluster.org/13388
Comment 7 krishnaram Karthick 2016-02-12 00:05:08 EST
Verified the build in glusterfs-3.7.5-19. 

Enabled quota on a tiered volume and set limit to root, ran several promotion/demotions, attach tier and detach tier. Data usage reported actual value.
Comment 9 errata-xmlrpc 2016-03-01 01:09:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.