Bug 1305029 - [quota]: Incorrect disk usage shown on a tiered volume
[quota]: Incorrect disk usage shown on a tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.7
All Unspecified
urgent Severity high
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged, ZStream
Depends On: 1304684 1304970
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-05 06:27 EST by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1304970
Environment:
Last Closed: 2016-04-19 03:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-05 06:34:45 EST
REVIEW: http://review.gluster.org/13388 (quota: Fix incorrect disk usage shown on a tiered volume) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-02-11 01:12:17 EST
COMMIT: http://review.gluster.org/13388 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 0c3e7174ac74f7222f3b8a27fe8b146b4c104852
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Fri Feb 5 12:17:22 2016 +0530

    quota: Fix incorrect disk usage shown on a tiered volume
    
    When quota is enabled on a tiered volume, incorrect data usage is
    shown, it is because, during the process of migrating files in tiering,
    we are accounting both for the src file and dst file at some point. By the
    time we make the srcfile as a T file, marker has already accounted the
    contri and has updated it's parent and also we are not accounting for the
    truncate operation done, which accounts to incorrect data usage even after
    unlinking the file. The size can increase drastically with multiple promotes
    and demotes since the contri keeps changing and the parent is being updated.
    
            Backport of http://review.gluster.org/#/c/13363/
    
    > Change-Id: Ie567228786713d7dc257ff374a69ad3be40f9e82
    > BUG: 1304970
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    
    Change-Id: I72138aa3bb9ad180287e9bed916b845ec028f259
    BUG: 1305029
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13388
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:23:05 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Kaushal 2016-04-19 03:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.