Bug 1304970 - [quota]: Incorrect disk usage shown on a tiered volume
[quota]: Incorrect disk usage shown on a tiered volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
All Unspecified
urgent Severity high
: ---
: ---
Assigned To: Manikandan
: Triaged, ZStream
Depends On: 1304684
Blocks: 1305029
  Show dependency treegraph
 
Reported: 2016-02-05 02:31 EST by Manikandan
Modified: 2016-06-16 09:57 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1304684
: 1305029 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:57:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-05 02:46:06 EST
REVIEW: http://review.gluster.org/13363 (quota: Fix incorrect disk usage shown on a tiered volume) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-02-05 06:26:35 EST
REVIEW: http://review.gluster.org/13363 (quota: Fix incorrect disk usage shown on a tiered volume) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Vijay Bellur 2016-02-11 01:09:29 EST
COMMIT: http://review.gluster.org/13363 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit b8bd9a6e6e3f50ede4c25dcfc0a05aad53e66c79
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Fri Feb 5 12:17:22 2016 +0530

    quota: Fix incorrect disk usage shown on a tiered volume
    
    When quota is enabled on a tiered volume, incorrect data usage is
    shown, it is because, during the process of migrating files in tiering,
    we are accounting both for the src file and dst file at some point. By the
    time we make the srcfile as a T file, marker has already accounted the
    contri and has updated it's parent and also we are not accounting for the
    truncate operation done, which accounts to incorrect data usage even after
    unlinking the file. The size can increase drastically with multiple promotes
    and demotes since the contri keeps changing and the parent is being updated.
    
    Change-Id: Ie567228786713d7dc257ff374a69ad3be40f9e82
    BUG: 1304970
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13363
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 4 Niels de Vos 2016-06-16 09:57:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.