Bug 1305900 - use different bus for cdrom when q35 chipset is used
use different bus for cdrom when q35 chipset is used
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Shmuel Melamud
Shira Maximov
:
: 1322248 (view as bug list)
Depends On: 1306586
Blocks: oVirt_Q35_tech_preview_support 1365938
  Show dependency treegraph
 
Reported: 2016-02-09 09:34 EST by Martin Polednik
Modified: 2016-08-10 10:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Added the ability to configure different bus interfaces (IDE, SCSI, and SATA) for different virtual machine chipsets. By default, the SATA interface is used for the Q35 chipset.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:38:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 56588 master MERGED core: Use SATA CD-ROM for q35 chipset 2016-05-02 11:19 EDT

  None (edit)
Description Martin Polednik 2016-02-09 09:34:59 EST
Engine currently uses IDE bus for all cdrom devices. That is fine for i440fx chipset, but not for q35. As we would like to move to q35 tech preview or even default at some point, different bus must be used (e.g. scsi, sata).
Comment 1 Red Hat Bugzilla Rules Engine 2016-02-09 09:49:39 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Yaniv Kaul 2016-03-13 12:06:28 EDT
Moving to 4.1, as it looks like it'll be 7.3 based.
Comment 3 Michal Skrivanek 2016-03-31 01:00:00 EDT
*** Bug 1322248 has been marked as a duplicate of this bug. ***
Comment 4 Michal Skrivanek 2016-04-15 05:34:14 EDT
this is minor and more of a bug, blocking a possible tech preview during 4.0 lifecycle (there's no code on our side needed other than this fix AFAIK, so as soon as 7.3 is out we can semi-support q35...)
i'll trade it with another 4.0 bug and move back
Comment 5 Sandro Bonazzola 2016-05-02 05:47:36 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 6 Shira Maximov 2016-06-09 07:28:26 EDT
verified on : 
oVirt Engine Version: 4.1.0-0.0.master.20160606111312.gitc7af584.el7.centos

verification steps: 
1. create VM with CD-rom 
2. change the emulated machine to q35 , and later for  pc-i440fx-rhel7.2.0
3. start the VM 
4. look at the VM devices 

For VM with q35 chipset - > SATA added 
For VM with i440fx chipset -> controller added.
Comment 7 Sandro Bonazzola 2016-07-05 03:38:15 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.