This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306024 - Restricting project counts and names
Restricting project counts and names
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Paul Weil
weiwei jiang
:
Depends On:
Blocks: 1389522
  Show dependency treegraph
 
Reported: 2016-02-09 16:01 EST by Boris Kurktchiev
Modified: 2017-03-08 13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1389522 (view as bug list)
Environment:
Last Closed: 2016-09-28 07:38:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Kurktchiev 2016-02-09 16:01:45 EST
Description of problem:
I am in the need of restricting the project count and the name a user can have. I have been provided with: https://github.com/openshift/origin/pull/6571 and https://github.com/openshift/openshift-docs/pull/1476/files as pointers by rjhowe@redhat.com. Based on the information he mentioned that this in upstream with possible 3.2 release. 

In our environment (education space), it is a pretty important thing to have as resources are a bit more finite and project count limits in conjunction with resource quota and limits allows us to maximize what we offer our customers for free.

The second part of the bug report neither myself nor Ryan have been able to find much info on. In v2 currently, we are able to restrict the namespace by doing a couple of simple code modifications which allow us to restrict the project name to the user's username (as an example), thus providing a simple audit trail for troubleshooting/etc. Will there be any chance of getting this functionality added, as modifying v3 is a bit harder than it is with v2 :)?
Comment 1 Dan McPherson 2016-02-10 09:37:16 EST
This is related:

https://trello.com/c/GsCfvXWA

Will release with 3.2.  This will allow you to configure the system so only N projects can be created per user.
Comment 2 Boris Kurktchiev 2016-02-10 09:48:42 EST
So I am guessing that my second request should be filed as an RFE? Also, there is one last thing that we are currently able to do in v2 with a few lines of code changed. The public hostname of a route. Right now we can only limit to say *.ose.devapps.unc.edu in v3, but is there some mechanism to insert say their username for their project ex: User: boris hostnames available: *-boris.ose.devapps.unc.edu
Comment 4 Cesar Wong 2016-02-10 10:06:56 EST
Boris there isn't a current mechanism that I know of to default the route name. Sounds like another RFE.
Comment 5 Dan McPherson 2016-04-15 09:14:53 EDT
This is similar to: https://bugzilla.redhat.com/show_bug.cgi?id=1257760
Comment 6 weiwei jiang 2016-05-06 06:48:22 EDT
Since the feature "project request limitation" will be released in 3.2, so verify this.

Note You need to log in before you can comment on or make changes to this bug.