This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306397 - [openstack] Backport bulk inspection error output [NEEDINFO]
[openstack] Backport bulk inspection error output
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity medium
: y3
: 7.0 (Kilo)
Assigned To: Brad P. Crochet
Omri Hochman
:
Depends On:
Blocks: 1309824
  Show dependency treegraph
 
Reported: 2016-02-10 12:26 EST by Joe Talerico
Modified: 2016-02-18 13:52 EST (History)
13 users (show)

See Also:
Fixed In Version: python-rdomanager-oscplugin-0.0.10-28.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1309824 (view as bug list)
Environment:
Last Closed: 2016-02-18 11:53:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
athomas: needinfo? (tsedovic)


Attachments (Terms of Use)

  None (edit)
Description Joe Talerico 2016-02-10 12:26:11 EST
Description of problem:
OSP7 openstack baremetal bulk introspection returns that there was a error, but does not return which nodes had errors. Liberty has a patch to have a bit more output with failures.
Comment 2 Angus Thomas 2016-02-11 06:01:07 EST
We can't backport this into the 7.3 release, because we're out of time and this is essentially an RFE, rather than a fix for a regression. 

In addition to aaddressing this in the next release, we can look into creating a validation check to assist with this. Those are consumable by field engineers deploying OSP director as soon as they're written and don't need to wait for a product release. 

Tomas, can you please look into addressing this issue with a validation?
Comment 3 Dan Yasny 2016-02-11 12:17:58 EST
duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1302386 maybe?
Comment 4 Mike Burns 2016-02-11 12:27:37 EST
(In reply to Dan Yasny from comment #3)
> duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1302386 maybe?

No, this bug handles the return code for bulk introspection.  The other one just makes a host failure more visible.  They're similar, but not duplicates.
Comment 6 Dan Macpherson 2016-02-16 01:49:04 EST
Mike, do you know if this bug will make it to 7.3? Angus seemed to indicate that it wouldn't in comment #2.
Comment 8 errata-xmlrpc 2016-02-18 11:53:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.