Bug 1309824 - [openstack] Backport bulk inspection error output
[openstack] Backport bulk inspection error output
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity medium
: async
: 7.0 (Kilo)
Assigned To: RHOS Maint
Omri Hochman
: TestOnly
Depends On: 1306397
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 13:52 EST by Scott Lewis
Modified: 2016-03-09 15:03 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306397
Environment:
Last Closed: 2016-03-09 15:03:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Omri Hochman 2016-03-09 12:09:09 EST
Verified with:
 python-rdomanager-oscplugin-0.0.10-28.el7ost.noarch :
 python-ironic-discoverd-1.1.0-8.el7ost.noarch

There's an error during introspection specify the nodes UUID that had the issue.  

ERROR: rdomanager_oscplugin.utils.wait_for_node_discovery Discovery didn't finish for nodes 48f1f5a1-e505-41a6-aef5-d46b2f43a159,66973a45-17c4-4b72-aa18-9aac6
Setting manageable nodes to available...
Node 6f8bb64c-ada1-4bce-9652-aaa0c49a7da6 has been set to available.
Node 48f1f5a1-e505-41a6-aef5-d46b2f43a159 has been set to available.
Node 3a949861-c81f-43c0-ba72-e1a7e42bdd85 has been set to available.
Node b1f74d01-24eb-44a8-a236-f58337cea602 has been set to available.
Node 1084dad4-6eca-4417-ab42-278ad3dbcf5f has been set to available.
Node 66973a45-17c4-4b72-aa18-9aac6f3c68b6 has been set to available.
Node 318e07df-2738-44e8-8672-4907c571b699 has been set to available.
Discovery completed.

Note : we would prefer the Error message to be after the "Discovery completed" , so in case there are many nodes doing introspection the error will be more noticeable.  

See: 
https://bugzilla.redhat.com/show_bug.cgi?id=1316213
Comment 5 errata-xmlrpc 2016-03-09 15:03:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0424.html

Note You need to log in before you can comment on or make changes to this bug.