Bug 1306585 - Network Import dialogue will not close on Cancel
Network Import dialogue will not close on Cancel
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Marcin Mirecki
Petr Matyáš
:
: 1215709 1313191 (view as bug list)
Depends On:
Blocks: 1327382
  Show dependency treegraph
 
Reported: 2016-02-11 06:34 EST by Petr Matyáš
Modified: 2016-04-21 10:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:42:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
dialogue screenshot (35.07 KB, image/png)
2016-02-11 06:34 EST, Petr Matyáš
no flags Details
engine log (180.47 KB, text/plain)
2016-02-11 06:35 EST, Petr Matyáš
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53479 master MERGED webadmin: Network Import dialog open/cancel fails 2016-02-29 02:29 EST
oVirt gerrit 54279 ovirt-engine-3.6 MERGED webadmin: Network Import dialog open/cancel fails 2016-03-10 03:07 EST

  None (edit)
Description Petr Matyáš 2016-02-11 06:34:05 EST
Created attachment 1123124 [details]
dialogue screenshot

Description of problem:
When I open network import dialogue and then click on cancel, nothing happens. Also when I close this dialogue with close button on top right I can't open any more dialogues.

Version-Release number of selected component (if applicable):
3.6.3-2

How reproducible:
always

Steps to Reproduce:
1. go to networks tab in webadmin
2. click on import button
3. click on Cancel button

Actual results:
nothing happens

Expected results:
dialogue closes

Additional info:
In console log I can see only too much recursion message with:
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892
EventLoop.prototype.enter()
 script.js:347
ThreadActor.prototype.unsafeSynchronize()
 script.js:1085
ThreadActor.prototype._addSource()
 script.js:1945
ThreadActor.prototype.onNewScript()
 script.js:1892

And in engine.log only this message seems relevant:
2016-02-11 12:30:20,536 WARN  [org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (VdsDeploy) [] Cannot validate host name settings, reason: resolved host does not match any of the local addresses
Comment 1 Petr Matyáš 2016-02-11 06:35 EST
Created attachment 1123126 [details]
engine log
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-12 04:46:32 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Marcin Mirecki 2016-02-12 10:39:28 EST
One more problem was that the dialog could only be opened once. When closed (using the dialog x icon, which worked), it would never open again.
Related is the external network provider network dialog (same code), which should also be checked.
Comment 4 Dan Kenigsberg 2016-03-02 04:32:04 EST
*** Bug 1313191 has been marked as a duplicate of this bug. ***
Comment 5 Dan Kenigsberg 2016-03-02 04:33:06 EST
(moving back to POST, as a backport is required)
Comment 6 Michael Burman 2016-03-02 04:35:16 EST
Dan

Please note that the problems starting once pressing the 'Import' button. from here many parts of the UI will stop working(including the 'Cancel' button)
Comment 7 Marcin Mirecki 2016-03-07 03:57:21 EST
*** Bug 1215709 has been marked as a duplicate of this bug. ***
Comment 8 Petr Matyáš 2016-03-31 04:59:21 EDT
Verified on 3.6.5-1

Note You need to log in before you can comment on or make changes to this bug.