Bug 1308792 - No sound on XPS13, Kernel 4.5RC4 but works in 4.4
No sound on XPS13, Kernel 4.5RC4 but works in 4.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1317214 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 00:47 EST by darrell pfeifer
Modified: 2016-08-22 18:28 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 18:28:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working and non-working kernel log snippet (9.24 KB, text/plain)
2016-02-16 00:47 EST, darrell pfeifer
no flags Details

  None (edit)
Description darrell pfeifer 2016-02-16 00:47:30 EST
Created attachment 1127491 [details]
working and non-working kernel log snippet

Description of problem:

Sound worked on kernel 4.4 but is dummy output on 4.5RC4


Version-Release number of selected component (if applicable):

4.4.0-1.fc24.x86_64 (working sound)
4.5.0-0.rc4.git0.1.fc24  (only dummy output)

How reproducible:


Steps to Reproduce:
1. Boot in 4.4, sound playback device shows as broadwell-rt286
2. Boot into 4.5RC4 sound playback device shows as dummy output
3. Boot back into 4.4 and rt286 sound reappears.

Actual results:


Expected results:


Additional info:

DMI: Dell Inc. XPS 13 9343/0310JH, BIOS A07 11/11/2015


The attachment is a snippet of the kernel log from the properly working 4.4 followed by a snippet from 4.5

The first missing line in the non-working output is

sst-acpi INT3438:00: DesignWare DMA Controller, 8 channels
Comment 1 Niccolò Belli 2016-03-02 04:06:38 EST
I confirm there is a regression in 4.5.
Comment 2 Guillaume Kulakowski 2016-03-02 06:48:39 EST
I have no sound on 4.4 with a XPS 13 9343 / A07.

~~~
rpm -qa | grep alsa       
alsa-ucm-1.0.29-2.fc23.x86_64
alsa-utils-1.0.29-2.fc23.x86_64
alsa-lib-1.0.29-2.fc23.x86_64
alsa-plugins-pulseaudio-1.0.29-2.fc23.x86_64
~~~

~~~
rpm -qa | grep kernel | grep 4\.4
kernel-headers-4.4.2-301.fc23.x86_64
kernel-core-4.4.2-301.fc23.x86_64
kernel-4.4.2-301.fc23.x86_64
kernel-modules-4.4.2-301.fc23.x86_64
~~~
Comment 3 darrell pfeifer 2016-03-08 09:37:59 EST
Still no sound in 4.5.0-0.rc7.git0.1.fc25.x86_64.

Please use this bug for problems with 4.5. Sound works fine for me in 4.4
Comment 4 darrell pfeifer 2016-03-08 10:52:41 EST
In 4.5 the config options have changed

# grep SOC_INTEL /boot/*config*
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_SST=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_SST_ACPI=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_HASWELL=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_BAYTRAIL=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_HASWELL_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_BYT_RT5640_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_BYT_MAX98090_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_BROADWELL_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_BYTCR_RT5640_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_CHT_BSW_RT5672_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_CHT_BSW_RT5645_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_CHT_BSW_MAX98090_TI_MACH=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_SKYLAKE=m
/boot/config-4.4.0-1.fc24.x86_64:CONFIG_SND_SOC_INTEL_SKL_RT286_MACH=m




/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SST=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SST_ACPI=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SST_MATCH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_BYTCR_RT5640_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_BYTCR_RT5651_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_CHT_BSW_RT5672_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_CHT_BSW_RT5645_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_CHT_BSW_MAX98090_TI_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SKYLAKE=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SKL_RT286_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SKL_NAU88L25_SSM4567_MACH=m
/boot/config-4.5.0-0.rc7.git0.1.fc25.x86_64:CONFIG_SND_SOC_INTEL_SKL_NAU88L25_MAX98357A_MACH=m
Comment 5 darrell pfeifer 2016-03-08 12:03:43 EST
The haswell and broadwell module code is still in the kernel tree

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/sound/soc/intel/boards

but the modules aren't being built in 4.5

# ls -l /lib/modules/4.4.0-1.fc24.x86_64/kernel/sound/soc/intel/boards
total 36
-rw-r--r--. 1 root root 2896 Jan 11 09:33 snd-soc-skl_rt286.ko.xz
-rw-r--r--. 1 root root 3312 Jan 11 09:33 snd-soc-sst-broadwell.ko.xz
-rw-r--r--. 1 root root 2964 Jan 11 09:33 snd-soc-sst-bytcr-rt5640.ko.xz
-rw-r--r--. 1 root root 2764 Jan 11 09:33 snd-soc-sst-byt-max98090-mach.ko.xz
-rw-r--r--. 1 root root 3004 Jan 11 09:33 snd-soc-sst-byt-rt5640-mach.ko.xz
-rw-r--r--. 1 root root 3500 Jan 11 09:33 snd-soc-sst-cht-bsw-max98090_ti.ko.xz
-rw-r--r--. 1 root root 4048 Jan 11 09:33 snd-soc-sst-cht-bsw-rt5645.ko.xz
-rw-r--r--. 1 root root 3816 Jan 11 09:33 snd-soc-sst-cht-bsw-rt5672.ko.xz
-rw-r--r--. 1 root root 2612 Jan 11 09:33 snd-soc-sst-haswell.ko.xz

[# ls -l /lib/modules/4.5.0-0.rc7.git0.1.fc25.x86_64/kernel/sound/soc/intel/boards
total 36
-rw-r--r--. 1 root root 3948 Mar  7 09:24 snd-skl_nau88l25_max98357a.ko.xz
-rw-r--r--. 1 root root 4224 Mar  7 09:24 snd-soc-skl_nau88l25_ssm4567.ko.xz
-rw-r--r--. 1 root root 3440 Mar  7 09:24 snd-soc-skl_rt286.ko.xz
-rw-r--r--. 1 root root 3724 Mar  7 09:24 snd-soc-sst-bytcr-rt5640.ko.xz
-rw-r--r--. 1 root root 3312 Mar  7 09:24 snd-soc-sst-bytcr-rt5651.ko.xz
-rw-r--r--. 1 root root 3564 Mar  7 09:24 snd-soc-sst-cht-bsw-max98090_ti.ko.xz
-rw-r--r--. 1 root root 4056 Mar  7 09:24 snd-soc-sst-cht-bsw-rt5645.ko.xz
-rw-r--r--. 1 root root 3848 Mar  7 09:24 snd-soc-sst-cht-bsw-rt5672.ko.xz
Comment 6 bryant 2016-03-10 13:53:11 EST
I have the XPS 13 9343 laptop as well and I have sound problems on 4.4.4. Should I file a new bug for that then as suggested in comment 3 or can we have a single report for kernels 4.4 and 4.5?
Comment 7 darrell pfeifer 2016-03-10 14:05:06 EST
They are different issues.

4.4 was the first kernel to have sound available for the I2S hardware. People who upgraded to that kernel had various issues that kept sound from working.  The 4.4.4-300+ kernels starting at the end of last week are an attempt to deal with that problem.

http://koji.fedoraproject.org/koji/buildinfo?buildID=743760

The 4.5 rawhide kernels are using the same sound hardware as 4.4, so if you had working sound somewhere in 4.4 you should have it in 4.5. At this point is looks like a configuration issue to me.

Please try to report the 4.4 issues elsewhere
Comment 8 Niccolò Belli 2016-03-10 14:07:04 EST
Please don't pollute this bug report if you didn't already have i2s sound working on 4.4. This is 4.5 ONLY.
Comment 9 Niccolò Belli 2016-03-10 14:10:18 EST
@darrell pfeifer
I don't think this is a configuration issue because I have the very same problem on Arch Linux with a self compiled kernel. It still may be a configuration issue if some *default* config options changed with 4.5.
Comment 10 Niccolò Belli 2016-03-10 14:19:22 EST
Maybe I will bisect it this weekend *if* I will find enough free time. If someone else is already bisecting it or is willing to please let me know.
Comment 11 Josh Boyer 2016-03-10 14:21:58 EST
Do you have CONFIG_DW_DMAC_CORE=y in your config?  If not, then the modules aren't available.  This was changed with:

commit a92ea59b74e231cc0a969afa8d71fa314d5860f2
Author: Jie Yang <yang.jie@intel.com>
Date:   Tue Nov 24 22:01:21 2015 +0800

    ASoC: Intel: sst: only select sst-firmware when DW DMAC is built-in


which sounds all fine, except it's pretty terrible from a distribution standpoint.  Now we're left with the choice of everyone running an x86_64 kernel using Fedora having to carry DW_DMAC_CORE in-memory regardless of whether or not their machine use it (which most don't), or leaving the modules missing for the few machines that actually need it.
Comment 12 darrell pfeifer 2016-03-10 14:27:42 EST
There has been some very recent discussion about DW_DMAC_CORE on the alsa list. The end of the thread...

http://mailman.alsa-project.org/pipermail/alsa-devel/2016-March/105574.html

So we're not getting sound because the commit expects to see built-in rather than a module?
Comment 13 Josh Boyer 2016-03-10 14:35:22 EST
(In reply to darrell pfeifer from comment #12)
> There has been some very recent discussion about DW_DMAC_CORE on the alsa
> list. The end of the thread...
> 
> http://mailman.alsa-project.org/pipermail/alsa-devel/2016-March/105574.html
> 
> So we're not getting sound because the commit expects to see built-in rather
> than a module?

At least in Fedora I believe that is what is happening.  We still have the various sst modules set to =m in our config hunks, but we also have CONFIG_DW_DMAC_CORE=m as well.  Which means when all the hunks are put together, we wind up with the sst modules disabled.
Comment 14 charles profitt 2016-03-11 22:44:54 EST
Is it possible to set CONFIG_ACPI_REV_OVERRIDE_POSSIBLE in the Kernel again to resolve this issue?

https://bugs.archlinux.org/task/47989
Comment 15 darrell pfeifer 2016-03-11 22:50:35 EST
No, that would give HDA sound. It is better to go in the "new" directin.

DMC_CORE could be compiled into the kernel but that would result in a larger kernel size even for people who didn't need it.
Comment 16 Niccolò Belli 2016-03-12 10:22:47 EST
I confirm that CONFIG_DW_DMAC_CORE=y fixed my issue. Unfortunately no sane maintainer will statically compile it, so I guess we're out of luck. Did someone find a possible solution?
Comment 17 Josh Boyer 2016-03-12 19:57:00 EST
*** Bug 1317214 has been marked as a duplicate of this bug. ***
Comment 18 charles profitt 2016-03-12 22:16:36 EST
I was able to get things working by applying the alsamixer settings mentioned in this blog post: "http://forthescience.org/blog/tag/xps13.html"
Comment 19 darrell pfeifer 2016-03-13 15:27:41 EDT
@Charles Profitt

Are you sure you're using a Fedora 4.5 kernel? The alsamixer fix has worked on 4.4 but in 4.5 the modules aren't loaded at all (so the device won't show in alsamixer)
Comment 20 charles profitt 2016-03-13 22:53:56 EDT
@darrel: You are correct -- this is for 4.4 -- I was tracking two bugs and commented on the wrong one. My apologies.
Comment 21 Mykola Dvornik 2016-03-15 12:02:06 EDT
Here is the copr with the 4.5.0-300 F23 rebuild with 'DW_DMAC=y' and 'SND_SOC_INTEL_BROADWELL_MACH=m' https://copr.fedorainfracloud.org/coprs/godsic/kernel-rawhide-xps13/
Comment 22 bryant 2016-03-15 17:18:18 EDT
@Mykola Dvornik - I just tried your copr on my XPS13, and now the sound device is showing up, but I'm not getting any sound output. I've tried playing something in Firefox and also using the speaker test functionality in Gnome Settings. I don't see any errors in dmesg at all, and the audio-related output is:

$ dmesg | grep audio
[    4.013355] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.220035] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
[    4.220040] haswell-pcm-audio haswell-pcm-audio: fw image intel/IntcPP01.bin not available(-2)
[    4.220799] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[    4.234044] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System Pin mapping ok
[    4.234107] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload0 Pin mapping ok
[    4.234165] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload1 Pin mapping ok
[    4.234223] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Loopback Pin mapping ok
[    4.247371] broadwell-audio broadwell-audio: rt286-aif1 <-> snd-soc-dummy-dai mapping ok
[    4.261667] input: broadwell-rt286 Headset as /devices/pci0000:00/INT3438:00/broadwell-audio/sound/card1/input16
[   30.608958] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[   57.112641] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[   84.625067] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[  103.468057] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
Comment 23 Mykola Dvornik 2016-03-15 17:23:11 EDT
Please apply the alsa settings as explained in http://forthescience.org/blog/tag/xps13.html

(In reply to bryant.mairs from comment #22)
> @Mykola Dvornik - I just tried your copr on my XPS13, and now the sound
> device is showing up, but I'm not getting any sound output. I've tried
> playing something in Firefox and also using the speaker test functionality
> in Gnome Settings. I don't see any errors in dmesg at all, and the
> audio-related output is:
> 
> $ dmesg | grep audio
> [    4.013355] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops
> i915_audio_component_bind_ops [i915])
> [    4.220035] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for
> intel/IntcPP01.bin failed with error -2
> [    4.220040] haswell-pcm-audio haswell-pcm-audio: fw image
> intel/IntcPP01.bin not available(-2)
> [    4.220799] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox
> readback FW info: type 01, - version: 00.00, build 77, source commit id:
> 876ac6906f31a43b6772b23c7c983ce9dcb18a19
> [    4.234044] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System
> Pin mapping ok
> [    4.234107] broadwell-audio broadwell-audio: snd-soc-dummy-dai <->
> Offload0 Pin mapping ok
> [    4.234165] broadwell-audio broadwell-audio: snd-soc-dummy-dai <->
> Offload1 Pin mapping ok
> [    4.234223] broadwell-audio broadwell-audio: snd-soc-dummy-dai <->
> Loopback Pin mapping ok
> [    4.247371] broadwell-audio broadwell-audio: rt286-aif1 <->
> snd-soc-dummy-dai mapping ok
> [    4.261667] input: broadwell-rt286 Headset as
> /devices/pci0000:00/INT3438:00/broadwell-audio/sound/card1/input16
> [   30.608958] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox
> readback FW info: type 01, - version: 00.00, build 77, source commit id:
> 876ac6906f31a43b6772b23c7c983ce9dcb18a19
> [   57.112641] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox
> readback FW info: type 01, - version: 00.00, build 77, source commit id:
> 876ac6906f31a43b6772b23c7c983ce9dcb18a19
> [   84.625067] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox
> readback FW info: type 01, - version: 00.00, build 77, source commit id:
> 876ac6906f31a43b6772b23c7c983ce9dcb18a19
> [  103.468057] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox
> readback FW info: type 01, - version: 00.00, build 77, source commit id:
> 876ac6906f31a43b6772b23c7c983ce9dcb18a19
Comment 24 bryant 2016-03-15 17:42:00 EDT
Indeed, that got it working. Thanks Mykola. Let me know if I can test anything else for this.
Comment 25 darrell pfeifer 2016-03-19 01:24:11 EDT
Still no sound in 4.6.0-0.rc0.git11.1.fc25.x86_64. (The first 4,6 with new sound merges)
Comment 26 Griddick 2016-03-24 09:10:28 EDT
Hi, first time posting and not very experienced with linux. I had a crash on my DellXPS13 and now there is no sound coming from speakers or headphones. There was sound previously and everything was working fine. I have followed the advice here: https://fedoraproject.org/wiki/How_to_debug_sound_problems

But still no sound. The contents of alsa-info.txt is here: http://pastebin.com/n5kmr3ra

Any help much appreciated.
Comment 27 Przemyslaw Szypowicz 2016-04-11 12:33:20 EDT
Please take a look here: https://bugzilla.redhat.com/show_bug.cgi?id=1313434#c40
Comment 28 Griddick 2016-04-18 12:18:19 EDT
(In reply to Przemyslaw Szypowicz from comment #27)
> Please take a look here:
> https://bugzilla.redhat.com/show_bug.cgi?id=1313434#c40

Thanks. Looks like a very complex bug.
Comment 29 pip 2016-05-02 23:27:23 EDT
Got the sound device "Speaker playbac - broadwell-rt286" back with kernel upgrade 4.5.2-302. Alsa is 1.1.1, rel 1.fc24.
Comment 30 bryant 2016-05-04 13:56:39 EDT
I'm still running the kernel in the godsic copr, but I'm still missing my microphone. I know there's one on this laptop. Does this bug address that as well or should I file a new one?
Comment 31 pip 2016-05-04 14:41:13 EDT
BRYANT: Once your sound device is recognized, they both seem to work. Can you upgrade to kernel 4.5.2-302?
Comment 32 bryant 2016-05-04 15:04:09 EDT
I'd try but I don't know how to get the latest from koji or install RPMs downloaded off the packages website (getting dependency conflicts). This is why I've been using the copr. If I just try to update to rawhide I get the 4.6 kernel, which I don't think we're testing here.
Comment 33 Mads Villadsen 2016-05-17 08:07:01 EDT
I am running 4.5.4-300.fc24.x86_64 (from the Fedora 24 Beta) and initially I had no sound.

I do have the broadwell-rt286 sound output device but no input device.

After applying the alsamixer setting I got sound output again but still no input.
Comment 34 Mads Villadsen 2016-05-25 11:47:51 EDT
To try things out I installed the 4.5.2-300.xps13.fc24.x86_64 kernel from the copr repo.

Sadly it makes no difference when it comes to enabling any input device - so no microphone.
Comment 35 Mads Villadsen 2016-05-25 13:19:40 EDT
Just another update. I installed the alsa-ucm package and now everything works - both speakers and microphone.

I have this installed:

alsa-lib-1.1.1-1.fc24.i686
alsa-lib-1.1.1-1.fc24.x86_64
alsa-plugins-pulseaudio-1.1.1-1.fc24.x86_64
alsa-ucm-1.1.1-1.fc24.x86_64
alsa-utils-1.1.1-1.fc24.x86_64

kernel-4.5.5-300.fc24.x86_64
kernel-debug-devel-4.5.5-300.fc24.x86_64
kernel-modules-4.5.5-300.fc24.x86_64
Comment 36 Oleg Drokin 2016-05-26 12:15:24 EDT
I guess it should be noted that rawhide kernels 4.6.0, 4.7.0-rc0... still miss the CONFIG_SND_SOC_INTEL_BROADWELL_MACH and so the sound does not work on broadwell there.
Fedora24 is working fine with 4.5.5-300 indeed.
Comment 37 Daniel Farina 2016-07-03 13:54:47 EDT
Hello,

I'd like to confirm that my XPS 13 lost all sound when upgrading from Fedora 23 to Fedora 24, and that by compiling with CONFIG_SND_SOC_INTEL_BROADWELL_MACH I have retrieved sound.

Some backstory on my functional descent with sound on this hardware: at first, everything was fine for some months.

When Linux 4.4.something came around in the F23 cycle, I lost sound also, but recovered non-headphone and non-input sound via https://bbs.archlinux.org/viewtopic.php?pid=1610958#p1610958.

Finally, when upgrading F24, I lost sound and even the output entry in GNOME's sound panel.  CONFIG_SND_SOC_INTEL_BROADWELL_MACH made this reappear and my speaker output work once more. I don't seem to have input, however. I do not yet have confirmation one way or another on headphone output.
Comment 38 Oleg Drokin 2016-07-03 13:58:01 EDT
See bug 1351738 - the kernel config option was apparently lost by mistake
Comment 39 Daniel Farina 2016-07-03 14:04:43 EDT
Neat. I also played with my mixer settings and I can confirm sound input by doing stuff like:

 amixer -c 1 set 'Mic' on

One can see a list of these, of which at least 'SPO' and 'Mic' and perhaps the suggestively-named 'Headphone Jack' are important.  But less well understood to me are the others:

$  amixer -c 1 scontrols
Simple mixer control 'Master',0
Simple mixer control 'Headphone Jack',0
Simple mixer control 'Speaker',0
Simple mixer control 'Front DAC',0
Simple mixer control 'Front RECMIX',0
Simple mixer control 'Waves',0
Simple mixer control 'Mic',0
Simple mixer control 'ADC 0 Mux',0
Simple mixer control 'ADC 1 Mux',0
Simple mixer control 'ADC0',0
Simple mixer control 'AMIC',0
Simple mixer control 'DAC0',0
Simple mixer control 'HPO L',0
Simple mixer control 'HPO Mux',0
Simple mixer control 'HPO R',0
Simple mixer control 'Media0',0
Simple mixer control 'Media1',0
Simple mixer control 'RECMIX Beep',0
Simple mixer control 'RECMIX Line1',0
Simple mixer control 'RECMIX Mic1',0
Simple mixer control 'SPK Mux',0
Simple mixer control 'SPO',0

But, one perhaps can get some mileage out of messing with these. I don't know if this is a problem for fresh installs or whether that upgrade way back in F23 messed things up exactly once.
Comment 40 darrell pfeifer 2016-07-13 09:06:13 EDT
I've been compiling my own kernels for several kernel releases to get sound to work. The change to fix the kconfig problem has appeared 

http://mailman.alsa-project.org/pipermail/alsa-devel/2016-July/110086.html
Comment 41 Josh Boyer 2016-07-13 09:08:53 EDT
(In reply to darrell pfeifer from comment #40)
> I've been compiling my own kernels for several kernel releases to get sound
> to work. The change to fix the kconfig problem has appeared 
> 
> http://mailman.alsa-project.org/pipermail/alsa-devel/2016-July/110086.html

We've enabled CONFIG_DWMAC_CORE=y on all x86_64 kernels for quite some time.  The pointer to the patch is much appreciated, but you shouldn't need to build your own kernel at this point.
Comment 42 darrell pfeifer 2016-07-13 09:27:47 EDT
I tried 4.7.0-0.rc6.git0.1.fc25 when it came out. Only the dummy device shows, so no sound. Tried it again just to be sure and got the same result.

CONFIG_SND_SOC_INTEL_BROADWELL_MACH=m

isn't in the 4.7 config
Comment 43 Josh Boyer 2016-07-13 10:15:21 EDT
(In reply to darrell pfeifer from comment #42)
> I tried 4.7.0-0.rc6.git0.1.fc25 when it came out. Only the dummy device
> shows, so no sound. Tried it again just to be sure and got the same result.
> 
> CONFIG_SND_SOC_INTEL_BROADWELL_MACH=m
> 
> isn't in the 4.7 config

Ah.  The DW_DMAC_CORE change is only in the release branches.
Comment 44 darrell pfeifer 2016-08-22 18:28:02 EDT
Sound works properly with 4.8.0-0.rc3.git0.1.fc26.x86_64

Note You need to log in before you can comment on or make changes to this bug.