Bug 1309234 - Monitor mapping doesn't properly adjust resolutions
Monitor mapping doesn't properly adjust resolutions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1267184
Blocks: 1166319 1166298 1278016
  Show dependency treegraph
 
Reported: 2016-02-17 05:00 EST by xiaodwan
Modified: 2016-06-02 09:02 EDT (History)
16 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1267184
Environment:
Last Closed: 2016-05-10 17:22:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0832 normal SHIPPED_LIVE libgovirt, spice-gtk, usbredir, and virt-viewer bug fix update 2016-05-10 18:41:23 EDT

  None (edit)
Comment 6 xiaodwan 2016-03-06 22:35:15 EST
I updated the package to latest versions.
$ rpm -q spice-gtk virt-viewer
spice-gtk-0.26-7.el6.x86_64
virt-viewer-2.0-14.el6.x86_64

Steps:
1. Prepare a env with two physical monitors.
2. Install a spice guest and modify the configuration file.
$ cat .config/virt-viewer/settings 
[83865c8a-7ded-46e1-b803-584de8de0412]
monitor-mapping=1:2;2:1

[virt-viewer]
ask-quit=false
3. Run "virt-viewer -c qemu:///system 83865c8a-7ded-46e1-b803-584de8de0412 -f"

Actual Result:
The two displays appear in correct monitors and the resolution are correct, too.

So move the bug from ON_QA to VERIFIED.
Comment 9 errata-xmlrpc 2016-05-10 17:22:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.