Bug 1267184 - Monitor mapping doesn't properly adjust resolutions
Monitor mapping doesn't properly adjust resolutions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
: 1269918 (view as bug list)
Depends On: 1297830
Blocks: 1166319 1295396 1166298 1278016 1309234
  Show dependency treegraph
 
Reported: 2015-09-29 05:08 EDT by Tomas Jamrisko
Modified: 2016-11-03 21:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278016 1309234 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:10:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2015-09-29 05:08:16 EDT
Description of problem:
Mapping client:guest monitors results in their resolutions being switched

Version-Release number of selected component (if applicable):
spice-gtk3-0.26-5.el7

How reproducible:
100%

Steps to Reproduce:
1. RHEL guest with agent running
2. Client with 2 screens of different resolutions
3. Creat mapping for the guest in client's configuration file, 2:1;1:2
4. Connect to the guest with -f option

Actual results:
Displays are mapped as expected, except that resolution still honors 1:1;2:2, which results in scaling.

Expected results:
Resolution set on individual displays should account for remapping.
Comment 2 Pavel Grunt 2015-09-29 05:31:04 EDT
changing the component - virt-viewer takes care about monitor-mapping
Comment 3 Pavel Grunt 2015-09-29 05:48:29 EDT
Tomas, is the guest also RHEL 7.2?
I cannot reproduce the bug here - the guest always adjust to the window size.

A patch fixing a similar issue was posted: https://www.redhat.com/archives/virt-tools-list/2015-May/msg00013.html
Comment 4 Tomas Jamrisko 2015-09-30 04:46:26 EDT
No, the guest was RHEL6.7 (from nighlies), haven't tried with 7.2.
Comment 5 Jonathon Jongsma 2015-10-09 10:12:09 EDT
*** Bug 1269918 has been marked as a duplicate of this bug. ***
Comment 6 Jonathon Jongsma 2015-10-09 10:16:35 EDT
I just posted a patch to fix bug 1269918, but Pavel pointed out that this bug is the same. Here's the patch: https://www.redhat.com/archives/virt-tools-list/2015-October/msg00021.html
Comment 7 Fabiano Fidêncio 2015-10-21 09:26:34 EDT
(In reply to Jonathon Jongsma from comment #6)
> I just posted a patch to fix bug 1269918, but Pavel pointed out that this
> bug is the same. Here's the patch:
> https://www.redhat.com/archives/virt-tools-list/2015-October/msg00021.html

These 2 additional patches are also needed: http://www.redhat.com/archives/virt-tools-list/2015-October/msg00066.html and http://www.redhat.com/archives/virt-tools-list/2015-October/msg00067.html
Comment 8 Fabiano Fidêncio 2015-10-21 14:07:06 EDT
Just for the record, these are the necessary commits:
aff6c79ae080db286e4cb853cdfa02f2da0d0398
73b55b3e1b09c81cf72082b4ec49d66c79ba7dc7
96413a62663cb68f1559abac2c37b0eb80ddf4ab
Comment 9 xiaodwan 2016-02-17 04:58:24 EST
I can reproduce it on rhel7.2 release version.
$ rpm -q virt-viewer
virt-viewer-2.0-6.el7.x86_64

Steps:
1. Prepare a env with two physical monitors.
2. Install a spice guest and modify the configuration file.
$ cat .config/virt-viewer/settings 
[83865c8a-7ded-46e1-b803-584de8de0412]
monitor-mapping=1:2;2:1

[virt-viewer]
ask-quit=false
3. Run "virt-viewer -c qemu:///system 83865c8a-7ded-46e1-b803-584de8de0412 -f"

Actual Result:
The two displays appear in correct monitors but the resolution are incorrect.

Additional Info:
This issue also exists in rhel6.7, so clone it to rhel6.7.
Comment 11 xiaodwan 2016-04-14 04:04:08 EDT
I verified this bug following the steps in #comment 9 with virt-viewer-2.0-7.el7.x86_64. And the resolutions on two monitors are correct.

So move the bug from ON_QA to VERIFIED now.
Comment 13 errata-xmlrpc 2016-11-03 21:10:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.