Bug 1310117 - Unable to add Long Description for Orchestration based Catalog Items
Summary: Unable to add Long Description for Orchestration based Catalog Items
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.6.0
Assignee: Harpreet Kataria
QA Contact: Shveta
URL:
Whiteboard: stack:catalog
Depends On:
Blocks: 1310121 1311996
TreeView+ depends on / blocked
 
Reported: 2016-02-19 14:03 UTC by Krain Arnold
Modified: 2016-07-12 18:45 UTC (History)
6 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1311996 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:38:29 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Krain Arnold 2016-02-19 14:03:39 UTC
Description of problem:
The Long Description, although it is displayed in the service catalog, is not possible to edit in the Amazon and Azure Catalog items.


How reproducible:
100%

Steps to Reproduce:
1.Edit a catalog item for azure or amazon
2.Try to edit the Long Description. (There is no "details" tab...)

Actual results:
Descent into madness.

Expected results:
The ability to edit the long description.

Additional info:
This would be a neat feature to have because the Long Description can take raw HTML. This means we could drop in a "visualize" link in the long description that would take us to the armviz.io page for the template. (something like this: http://armviz.io/#/?load=https:%2F%2Fraw.githubusercontent.com%2FAzure%2Fazure-quickstart-templates%2Fmaster%2F201-vmss-windows-jumpbox%2Fazuredeploy.json .)

Either way, if the Long Description is displayed in the service catalog, there should be a way to edit it in the catalog item.

Comment 2 Krain Arnold 2016-02-24 13:40:57 UTC
This actually affects OpenStack as well, so essentially this is a problem for anything based on an orchestration template.

Comment 3 Krain Arnold 2016-02-24 13:41:58 UTC
A temporary work around is to export the service catalogs with a custom rake script, edit the long description manually, and import it back in.

Comment 5 Harpreet Kataria 2016-02-29 19:17:55 UTC
https://github.com/ManageIQ/manageiq/pull/7010

Comment 6 CFME Bot 2016-02-29 21:55:44 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/593b695d4f7cc77aa79124e1e7748cfd4d374f4b

commit 593b695d4f7cc77aa79124e1e7748cfd4d374f4b
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 29 14:14:34 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 29 14:14:34 2016 -0500

    Changes to show "Details" tab for all types of Catalog Items
    
    Show "Details" tab that has Long Description field for all types of Catalog Items if "Display in Catalog" is checked.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310117
    https://bugzilla.redhat.com/show_bug.cgi?id=1311996

 app/controllers/catalog_controller.rb        | 4 +++-
 app/views/catalog/_form.html.haml            | 8 ++++----
 app/views/catalog/_sandt_tree_show.html.haml | 4 ++--
 3 files changed, 9 insertions(+), 7 deletions(-)

Comment 7 CFME Bot 2016-02-29 23:58:15 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=66400e0c5a55a49e9f0c2773463e9b6b4504d3e1

commit 66400e0c5a55a49e9f0c2773463e9b6b4504d3e1
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 29 14:14:34 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 29 17:32:40 2016 -0500

    Changes to show "Details" tab for all types of Catalog Items
    
    Show "Details" tab that has Long Description field for all types of Catalog Items if "Display in Catalog" is checked.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310117
    https://bugzilla.redhat.com/show_bug.cgi?id=1311996
    (cherry picked from commit 593b695)

 app/controllers/catalog_controller.rb        | 4 +++-
 app/views/catalog/_form.html.haml            | 8 ++++----
 app/views/catalog/_sandt_tree_show.html.haml | 4 ++--
 3 files changed, 9 insertions(+), 7 deletions(-)

Comment 8 CFME Bot 2016-02-29 23:58:27 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ab7a91b2fe04404f9f657f99c67650280670b825

commit ab7a91b2fe04404f9f657f99c67650280670b825
Merge: 18241a3 66400e0
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 29 18:32:50 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Feb 29 18:32:50 2016 -0500

    Merge branch '55z_pr_7010' into '5.5.z'
    
    Changes to show "Details" tab for all types of Catalog Items
    
    Show "Details" tab that has Long Description field for all types of Catalog Items if "Display in Catalog" is checked.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310117
    https://bugzilla.redhat.com/show_bug.cgi?id=1311996
    (cherry picked from commit 593b695)
    
    @dclarizi please review, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/7010
    
    See merge request !826

 app/controllers/catalog_controller.rb        | 4 +++-
 app/views/catalog/_form.html.haml            | 8 ++++----
 app/views/catalog/_sandt_tree_show.html.haml | 4 ++--
 3 files changed, 9 insertions(+), 7 deletions(-)

Comment 9 Shveta 2016-04-17 21:46:15 UTC
Fixed.
Verified in 5.6.0.1-beta2.20160413141124_e25ac0e .

Comment 11 errata-xmlrpc 2016-06-29 15:38:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.