Bug 1311996 - Unable to add Long Description for Orchestration based Catalog Items
Unable to add Long Description for Orchestration based Catalog Items
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: Harpreet Kataria
Jeff Teehan
stack:catalog
: ZStream
Depends On: 1310117
Blocks: 1310121
  Show dependency treegraph
 
Reported: 2016-02-25 08:15 EST by John Prause
Modified: 2017-08-29 22:06 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1310117
Environment:
Last Closed: 2016-04-13 14:44:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2016-02-29 16:55:48 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/593b695d4f7cc77aa79124e1e7748cfd4d374f4b

commit 593b695d4f7cc77aa79124e1e7748cfd4d374f4b
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 29 14:14:34 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 29 14:14:34 2016 -0500

    Changes to show "Details" tab for all types of Catalog Items
    
    Show "Details" tab that has Long Description field for all types of Catalog Items if "Display in Catalog" is checked.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310117
    https://bugzilla.redhat.com/show_bug.cgi?id=1311996

 app/controllers/catalog_controller.rb        | 4 +++-
 app/views/catalog/_form.html.haml            | 8 ++++----
 app/views/catalog/_sandt_tree_show.html.haml | 4 ++--
 3 files changed, 9 insertions(+), 7 deletions(-)
Comment 4 CFME Bot 2016-02-29 18:58:19 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=66400e0c5a55a49e9f0c2773463e9b6b4504d3e1

commit 66400e0c5a55a49e9f0c2773463e9b6b4504d3e1
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 29 14:14:34 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 29 17:32:40 2016 -0500

    Changes to show "Details" tab for all types of Catalog Items
    
    Show "Details" tab that has Long Description field for all types of Catalog Items if "Display in Catalog" is checked.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310117
    https://bugzilla.redhat.com/show_bug.cgi?id=1311996
    (cherry picked from commit 593b695)

 app/controllers/catalog_controller.rb        | 4 +++-
 app/views/catalog/_form.html.haml            | 8 ++++----
 app/views/catalog/_sandt_tree_show.html.haml | 4 ++--
 3 files changed, 9 insertions(+), 7 deletions(-)
Comment 5 CFME Bot 2016-02-29 18:58:31 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ab7a91b2fe04404f9f657f99c67650280670b825

commit ab7a91b2fe04404f9f657f99c67650280670b825
Merge: 18241a3 66400e0
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 29 18:32:50 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Feb 29 18:32:50 2016 -0500

    Merge branch '55z_pr_7010' into '5.5.z'
    
    Changes to show "Details" tab for all types of Catalog Items
    
    Show "Details" tab that has Long Description field for all types of Catalog Items if "Display in Catalog" is checked.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310117
    https://bugzilla.redhat.com/show_bug.cgi?id=1311996
    (cherry picked from commit 593b695)
    
    @dclarizi please review, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/7010
    
    See merge request !826

 app/controllers/catalog_controller.rb        | 4 +++-
 app/views/catalog/_form.html.haml            | 8 ++++----
 app/views/catalog/_sandt_tree_show.html.haml | 4 ++--
 3 files changed, 9 insertions(+), 7 deletions(-)
Comment 7 Jeff Teehan 2016-04-06 18:31:23 EDT
Added a long long long description to catalog item in 5.5.3.3 using https://10.16.6.125/catalog/explorer

Long description persisted after edit and save.  Moving to Verified.
Comment 9 errata-xmlrpc 2016-04-13 14:44:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.