Bug 1311291 - Multiple Refresh Buttons on Click
Multiple Refresh Buttons on Click
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
medium Severity low
: GA
: 5.6.0
Assigned To: Martin Hradil
Jiri Stefanisin
ui:dialog:
: ZStream
: 1311292 1311293 1323556 1326984 (view as bug list)
Depends On:
Blocks: 1311998
  Show dependency treegraph
 
Reported: 2016-02-23 15:25 EST by Dustin Boyd
Modified: 2017-05-04 09:56 EDT (History)
13 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1311998 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:39:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Example result (57.67 KB, image/jpeg)
2016-02-23 15:25 EST, Dustin Boyd
no flags Details
screenshots-dialogs-automate-model to reproduce (546.74 KB, application/zip)
2016-02-24 23:04 EST, Kevin Morey
no flags Details

  None (edit)
Description Dustin Boyd 2016-02-23 15:25:54 EST
Created attachment 1129909 [details]
Screenshot of Example result

Description of problem:
When I have a Service Dialog that I set to a Refresh button and click the Refresh button, it spawns another Refresh button next to it.


Version-Release number of selected component (if applicable): 
5.5.2.4.20160127105142_395c086


How reproducible:
Reproducible on all elements in the customer's LDAP search calls.


Steps to Reproduce:
1. Create automate code that does an ldapsearch and returns dynamic dropdown values as a hash
2. Set the element to no auto refresh and no init with a refresh button
3. Test the button with a service creation

Actual results:
Multiple Refresh buttons spawned.


Expected results:
1 Refresh buttons regardless of how many times I click it.


Additional info:
Comment 2 Dustin Boyd 2016-02-23 15:36:22 EST
*** Bug 1311293 has been marked as a duplicate of this bug. ***
Comment 3 Dustin Boyd 2016-02-23 15:37:58 EST
*** Bug 1311292 has been marked as a duplicate of this bug. ***
Comment 5 Dustin Boyd 2016-02-23 15:56:28 EST
Steps to Reproduce:
4. Click a value in the dropdown and it will automatically create a new Refresh button
Comment 7 Kevin Morey 2016-02-24 23:04 EST
Created attachment 1130425 [details]
screenshots-dialogs-automate-model to reproduce
Comment 13 Harpreet Kataria 2016-04-12 15:25:42 EDT
*** Bug 1323556 has been marked as a duplicate of this bug. ***
Comment 14 Harpreet Kataria 2016-04-14 09:20:13 EDT
*** Bug 1326984 has been marked as a duplicate of this bug. ***
Comment 15 Jiri Stefanisin 2016-06-13 09:00:29 EDT
Verified on 5.6.0.9-rc2.20160531154046_b4e2f6d with no issues.
Comment 17 errata-xmlrpc 2016-06-29 11:39:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.