Bug 1312629 - Downloading on_demand RPM content results in 500 error
Downloading on_demand RPM content results in 500 error
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: satellite6-bugs
Jitendra Yejare
: Triaged
Depends On:
Blocks: 1321152 1321153
  Show dependency treegraph
 
Reported: 2016-02-28 03:42 EST by Mike McCune
Modified: 2017-07-26 15:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1321152 1321153 (view as bug list)
Environment:
Last Closed: 2016-07-27 05:23:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 1726 Normal CLOSED - CURRENTRELEASE Downloading on_demand RPM content results in 500 error 2016-03-23 15:00 EDT

  None (edit)
Description Mike McCune 2016-02-28 03:42:27 EST
1) Import Manifest
2) Enable RHEL 6Server repo
3) Set default download policy to "on_demand"
4) Sync
5) Register client, install a package from RHEL6 via 'yum install', note error

Main error:

Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352) OSError: [Errno 13] Permission denied: '/tmp/nectar-ssl_ca_cert-Q1HNWK'

Extended trace:


Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352) An unexpected error occurred while handling the request.
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352) Traceback (most recent call last):
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib/python2.7/site-packages/pulp/streamer/server.py", line 184, in _handle_get
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     self._download(catalog_entry, request, responder)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib/python2.7/site-packages/pulp/streamer/server.py", line 214, in _download
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     **catalog_entry.data)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib/python2.7/site-packages/pulp/plugins/importer.py", line 37, in get_downloader
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     nectar_config = importer_config_to_nectar_config(config.flatten(), working_dir=working_dir)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/nectar_config.py", line 51, in importer_config_to_nectar_config
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     download_config = DownloaderConfig(**download_config_kwargs)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib/python2.7/site-packages/nectar/config.py", line 134, in __init__
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     self._process_ssl_settings()
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib/python2.7/site-packages/nectar/config.py", line 171, in _process_ssl_settings
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     prefix=prefix)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib64/python2.7/tempfile.py", line 304, in mkstemp
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     return _mkstemp_inner(dir, prefix, suffix, flags)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)   File "/usr/lib64/python2.7/tempfile.py", line 239, in _mkstemp_inner
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352)     fd = _os.open(file, flags, 0600)
Feb 28 03:35:57 sat-r220-06.lab.eng.rdu2.redhat.com pulp_streamer[26539]: pulp.streamer.server:ERROR: (26539-72352) OSError: [Errno 13] Permission denied: '/tmp/nectar-ssl_ca_cert-Q1HNWK'


Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 pulp-infra@redhat.com 2016-02-28 04:30:23 EST
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 3 pulp-infra@redhat.com 2016-02-28 04:30:25 EST
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.
Comment 4 pulp-infra@redhat.com 2016-02-29 17:00:20 EST
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.
Comment 5 pulp-infra@redhat.com 2016-03-01 15:30:21 EST
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.
Comment 6 pulp-infra@redhat.com 2016-03-03 10:30:23 EST
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.
Comment 7 pulp-infra@redhat.com 2016-03-14 17:00:25 EDT
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.
Comment 8 Jitendra Yejare 2016-03-21 07:49:00 EDT
Hi Mike,

I was trying to verify this issue with Snap 4 of Sat 6.2.

I was trying to install katello-agent from tools package which has 'on-demand' download policy and I see errors for ERROR 22 - "The requested URL returned error: 400 Bad Request".

Output:
Downloading Packages:
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/gofer-2.6.8-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/katello-agent-2.2.6-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/pulp-rpm-handlers-2.6.0.20-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-gofer-2.6.8-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-gofer-proton-2.6.8-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-isodate-0.5.0-4.pulp.el6_6sat.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-pulp-agent-lib-2.6.0.20-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-pulp-common-2.6.0.20-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-pulp-rpm-common-2.6.0.20-1.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/python-qpid-proton-0.9-12.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.
https://dell-t7400-01.rhts.eng.bos.redhat.com/pulp/repos/Default_Organization/DEV/CV6/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.1/os/qpid-proton-c-0.9-12.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 400 Bad Request"
Trying other mirror.

I am not sure about the root cause about this error, whether its 'on_demand' policy or environment/setup issue.
Comment 9 jcallaha 2016-03-22 09:50:35 EDT
I'm not sure if this is related to https://bugzilla.redhat.com/show_bug.cgi?id=1318339 (which i am having difficulty reproducing. My last 10+ on_demand rpm installs have executed flawlessly.
Comment 10 pulp-infra@redhat.com 2016-03-23 15:00:30 EDT
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.
Comment 11 Chris Duryee 2016-03-24 15:16:22 EDT
The 400 error is a new issue that's specific to el6. I'll create a new BZ for it.
Comment 13 Jitendra Yejare 2016-04-01 08:00:40 EDT
As per comment 11 from beav : 400 error is not relates to this bug.

So tried installing another rpm from on-demand rhel 7 server custom repo.
And I can install it successfully.

Also the comment from 9 from jcallaha suggests that he also able to do the rpm installation from on_demand repo without any issues.


So moving this bug to verify.
Comment 15 errata-xmlrpc 2016-07-27 05:23:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.