Bug 1312649 - [Webadmin] Failed to attach an ISO domain to a DC from the webadmin
[Webadmin] Failed to attach an ISO domain to a DC from the webadmin
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3.2
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.3
: 3.6.3.4
Assigned To: Tal Nisan
Gil Klein
: Regression
: 1312650 1312651 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-28 07:22 EST by Gil Klein
Modified: 2016-03-10 07:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 07:49:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
UIException (155.43 KB, image/png)
2016-02-28 07:33 EST, Gil Klein
no flags Details
ui.log(masked) (149.92 KB, text/plain)
2016-02-29 04:46 EST, Gil Klein
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54183 master MERGED webadmin: Fix a bug in ISO domain attachment selection 2016-02-29 14:24 EST
oVirt gerrit 54184 ovirt-engine-3.6 MERGED webadmin: Fix a bug in ISO domain attachment selection 2016-02-29 14:24 EST
oVirt gerrit 54185 ovirt-engine-3.6.3 MERGED webadmin: Fix a bug in ISO domain attachment selection 2016-02-29 14:24 EST

  None (edit)
Description Gil Klein 2016-02-28 07:22:53 EST
Description of problem:
Uncaught exception occurred in the webadmin when attaching an ISO domain to a DC 


Version-Release number of selected component (if applicable):
rhevm-3.6.3.2-0.1.el6.noarch


How reproducible:
100% on this system


Steps to Reproduce:
1. Go to the storage tab
2. Select an ISO domain (unattached)
3. On the lower pane, select the Data center tab
4. click attach
5. Select one of the Data centers from the list
6. Click OK

Actual results:
Data center should be selected, and ISO domain should be attached to it


Expected results:
Uncaught exception occurred: Uncaught exception occurred. Please try reloading the page. Details: Exception caught: (TypeError) __gwtexception:

Additional info:

UI.log

2016-02-28 14:15:12,909 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-1) [] Permutation name: 2315F6F85423E584AFE3585F4C988A98
2016-02-28 14:15:12,909 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (ajp-/127.0.0.1:8702-1) [] Uncaught exception: : com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: b is null
	at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.7.0_95]
	at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.7.0_95]
	at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
	at com.google.gwt.view.client.SelectionChangeEvent.fire(SelectionChangeEvent.java:67) [gwt-servlet.jar:]
	at com.google.gwt.view.client.MultiSelectionModel.$resolveChanges(MultiSelectionModel.java:150) [gwt-servlet.jar:]
	at com.google.gwt.view.client.MultiSelectionModel.fireSelectionChangeEvent(MultiSelectionModel.java:143) [gwt-servlet.jar:]
	at com.google.gwt.view.client.SelectionModel$AbstractSelectionModel$1.execute(SelectionModel.java:128) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl.runScheduledTasks(SchedulerImpl.java:164) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.SchedulerImpl.$flushFinallyCommands(SchedulerImpl.java:270) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.exit(Impl.java:378) [gwt-servlet.jar:]
	at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: b is null
	at org.ovirt.engine.ui.common.widget.editor.EntityModelCellTable$1.onSelectionChange(EntityModelCellTable.java:223)
	at com.google.gwt.view.client.SelectionChangeEvent.dispatch(SelectionChangeEvent.java:98) [gwt-servlet.jar:]
	at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
	at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
	... 11 more
Comment 1 Gil Klein 2016-02-28 07:32:59 EST
*** Bug 1312650 has been marked as a duplicate of this bug. ***
Comment 2 Gil Klein 2016-02-28 07:33 EST
Created attachment 1131253 [details]
UIException
Comment 3 Yaniv Kaul 2016-02-28 10:13:07 EST
*** Bug 1312651 has been marked as a duplicate of this bug. ***
Comment 4 Oved Ourfali 2016-02-29 00:48:14 EST
Reducing urgency, and fixing version, as no ui exceptions will appear in 3.6.3.3 (the description states 3.6.3.2 while the bug was opened on 3.6.3.3).

Also, where are the logs? Does the attach actually work?
Anyway, should be re-tested with latest build.

Flow is storage, so moving for storage to investigate, and move to UX if relevant.
Comment 5 Red Hat Bugzilla Rules Engine 2016-02-29 00:48:20 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 6 Allon Mureinik 2016-02-29 01:23:56 EST
Tal, as the current QE contact, please take a look.
Comment 7 Gil Klein 2016-02-29 04:46 EST
Created attachment 1131471 [details]
ui.log(masked)
Comment 8 Gil Klein 2016-02-29 04:53:31 EST
(In reply to Oved Ourfali from comment #4)
> Reducing urgency, and fixing version, as no ui exceptions will appear in
> 3.6.3.3 (the description states 3.6.3.2 while the bug was opened on 3.6.3.3).
> 
> Also, where are the logs? Does the attach actually work?
UI.log now added.

The ISO domain fail to attached, so it has a high impact.
 
> Anyway, should be re-tested with latest build.
Just tested again with rhevm-3.6.3.3-0.1.el6.noarch

No UI exception now, but got the same exception in the UI.log
> 
> Flow is storage, so moving for storage to investigate, and move to UX if
> relevant.
Comment 9 Gil Klein 2016-02-29 07:11:14 EST
Moving back to 3.6.3. 

It has critical impact due to inability to attach an ISO domain to DC.
Comment 10 Tal Nisan 2016-02-29 14:31:26 EST
Just to sharpen up the steps to reproduce:
By default the first data center in the list is selected, if you keep this selection (or only have one data center) and click OK everything will run as it should.
The problem occurs when you have more than one data center and you choose one other than the first, the bug reproduces (no need to even click OK as the exception is thrown upon selection).
Comment 11 Tal Nisan 2016-02-29 14:38:37 EST
Note that during fixing and reproducing I've stumbled upon another bug in the area - although you can select a few data centers, attaching to multiple data centers fails and bug 1313042 was opened for that issue
Comment 12 Gil Klein 2016-03-01 16:52:25 EST
Verified with:

rhevm-3.6.3.4-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.