Bug 1312663 - [hosted-engine] - Adjust management network settings when deployed over VLAN interface/s
[hosted-engine] - Adjust management network settings when deployed over VLAN ...
Status: CLOSED WONTFIX
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network (Show other bugs)
1.2.6.1
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.5
: ---
Assigned To: Simone Tiraboschi
Ilanit Stein
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-28 10:46 EST by Michael Burman
Modified: 2017-05-11 05:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 08:42:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑3.6.z?
rule-engine: blocker?
mburman: planning_ack?
mburman: devel_ack?
mburman: testing_ack?


Attachments (Terms of Use)
screenshots (158.13 KB, application/x-gzip)
2016-02-28 10:46 EST, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2016-02-28 10:46:06 EST
Created attachment 1131296 [details]
screenshots

Description of problem:
[hosted-engine] - Adjust management network settings when deployed over VLAN interface/s

When self hosted engine is being deployed over VLAN it leads to situation that the management network is out-of-sync with host. Host is UP in engine.

It is caused by engine-setup deploying engine with management network which does not have VLAN tag by default

Self hosted engine should take care of this in the final configuration stage.

WA - edit the management network with vlan tag via the Networks main tab.

This was verified with success on 3.5.z(see BZ 1124207) and on 3.6.3(see BZ 1291083), so this is defiantly a regression.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.6.1-1.el6ev.noarch
3.5.8-0.1.el6ev

How reproducible:
100

Steps to Reproduce:
1. Configure VLAN tagged interface on physical host
2. Run hosted-engine --deploy 
3. Choose the VLAN interface to be used for the management network deployment
4. Finish the hosted engine deplyoment

Actual results:
Host is out-of-sync with the management network. There is a difference between host(vlan) and DC(no vlan)

Expected results:
Management network should be synced to host after deployment is done.
Self hosted engine should take care of this in the final configuration stage.

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2016-03-02 08:19:02 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Simone Tiraboschi 2016-03-02 08:42:21 EST
It has been fixed on 3.6 as for rhbz#1294348, we don't have other 3.5 builds.
Comment 3 Michael Burman 2016-03-02 08:47:19 EST
Simone, How this is relevant to BZ 1294348? 
In 3.6 it was fixed in BZ 1291083
Comment 4 Simone Tiraboschi 2016-03-02 08:50:09 EST
Michael, you are absolutely right: 1291083

Note You need to log in before you can comment on or make changes to this bug.