Bug 1313310 - [RFE]Add --no-encode option to the `glusterfind pre` command
[RFE]Add --no-encode option to the `glusterfind pre` command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
3.7.8
All All
medium Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: FutureFeature
Depends On: 1309277 1310080
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-03-01 06:26 EST by Aravinda VK
Modified: 2016-04-19 03:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1310080
Environment:
Last Closed: 2016-03-22 04:19:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-03-01 06:26:26 EST
+++ This bug was initially created as a clone of Bug #1310080 +++

+++ This bug was initially created as a clone of Bug #1309277 +++

Description of problem:

Glusterfind intentionally encodes(RFC 3986 https://www.ietf.org/rfc/rfc3986.txt) the file/dir path. Since the encoded file names are difficult to follow, there must an option to choose not to encode the glusterfind pre output file. 

Version-Release number of selected component (if applicable):

RHGS 3.1.1

How reproducible:

Always

Steps to Reproduce:

1. create a glusterfind session 

2. make some new directories or files with Russian name(Eg:-тестирование\ гластерфайнд)

3. Generate out file ,using glusterfind pre

Actual results:

test2%2F%2F%D1%82%D0%B5%D1%81%D1%82%D0%B8%D1%80%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5+%D0%B3%D0%BB%D0%B0%D1%81%D1%82%D0%B5%D1%80%D1%84%D0%B0%D0%B9%D0%BD%D0%B4


Expected results:

test2//тестирование гластерфайнд



Additional info:

--- Additional comment from Vijay Bellur on 2016-02-19 07:13:14 EST ---

REVIEW: http://review.gluster.org/13477 (tools/glusterfind: New option --no-encode) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-23 00:08:25 EST ---

REVIEW: http://review.gluster.org/13477 (tools/glusterfind: New option --no-encode) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-23 00:13:23 EST ---

REVIEW: http://review.gluster.org/13477 (tools/glusterfind: New option --no-encode) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-26 05:11:26 EST ---

COMMIT: http://review.gluster.org/13477 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 1b897c39ba8c0f1bf180316637cc2d87e6920800
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Feb 19 17:08:56 2016 +0530

    tools/glusterfind: New option --no-encode
    
    New option added to skip encoding path in output file. Also handled
    Unicode strings.
    
    File paths can have newline characters, to differentiate between each
    path patch is encoded according to
    RFC3986(https://www.ietf.org/rfc/rfc3986.txt). Due to this consumer
    applications have to decode the path before consuming it. With this
    option Paths are not encoded, can be directly consumed by
    applications.
    
    Unicode encoding is handled automatically
    
    BUG: 1310080
    Change-Id: I83d59831997dbd1264b48e9b1aa732c7dfc700b5
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13477
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 1 Vijay Bellur 2016-03-01 06:27:01 EST
REVIEW: http://review.gluster.org/13559 (tools/glusterfind: New option --no-encode) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2016-03-08 04:59:00 EST
COMMIT: http://review.gluster.org/13559 committed in release-3.7 by Aravinda VK (avishwan@redhat.com) 
------
commit f3b8a931b00cfd0ecee46599ed1ef1aaf236e148
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Feb 19 17:08:56 2016 +0530

    tools/glusterfind: New option --no-encode
    
    New option added to skip encoding path in output file. Also handled
    Unicode strings.
    
    File paths can have newline characters, to differentiate between each
    path patch is encoded according to
    RFC3986(https://www.ietf.org/rfc/rfc3986.txt). Due to this consumer
    applications have to decode the path before consuming it. With this
    option Paths are not encoded, can be directly consumed by
    applications.
    
    Unicode encoding is handled automatically
    
    BUG: 1313310
    Change-Id: I83d59831997dbd1264b48e9b1aa732c7dfc700b5
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13477
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    (cherry picked from commit 1b897c39ba8c0f1bf180316637cc2d87e6920800)
    Reviewed-on: http://review.gluster.org/13559
Comment 3 Kaushal 2016-04-19 03:21:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.