Bug 131346 - Text mode install on Mac - partitioning fails
Text mode install on Mac - partitioning fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 07:19 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 05:04:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-08-31 07:19:25 EDT
Description of problem: Since the iMac DV still doesn't do graphical
installs (bug #121265), I performed a text mode install. This machine
already had Fedora Core 2 (duke tree) running on it, with all updates
applied.

When it came to partitioning, I chose to have a clean install and
tried to get Disk Druid started, in text mode. Then I got a fun error :)


Version-Release number of selected component (if applicable):
Rawhide latest, 30th August 2004

How reproducible:
100%

Steps to Reproduce:
1. Perform a mac text install
2. Get to selecting the install type (NFS), then wait till you get to
disk partitioning options
3. Choosing automatic partition or even Disk Druid throws wonderful
errors, sig11'ing anaconda
  
Actual results:
When using Disk Druid:
Assertion (per_partition_is_active (part)) at disk.c:935 in function
ped_partition_get_flag() failed. <ignore> <cancel>
                                                                     
          
I click <ignore> at this stage (let's call this stage #1)

Assertion (part->disk_specific != NULL) at disk_mac.c:1137 in function
mac_partition_get_flag() failed. <ignore> <cancel>

Install will exit abnormally

If at stage #1, I click Cancel, I get:
File "/usr/bin/anaconda", line 1159, in ? intf.run(id, dispatch,
configFileData)File
"/usr/src/build/443503-ppc/install//usr/lib/anaconda/text.py", line
465, in run rc = apply(win, (selc.screen, ) + args)
File
"/usr/src/build/443503-ppc/install//usr/lib/anaconda/textw/partition_text.py",
line 1144, in __call__ self.populate()
File
"/usr/src/build/443503-ppc/install//usr/lib/anaconda/textw/partition_text.py",
line 125, in populate
        if getPartSizeMB(part) <=1.0 and not
part.get_flag(parted.PARTITION_BOOT):
error: Bug: Assertion
(ped_partition_is_active (part)) at disk.c:935 in function
ped_partition_get_flag() failed.
                                                                     
          
<ok><debug>

If <ok> is clicked, the installer exits...

Expected results:
I go past partitioning and all is well

Additional info:
If I choose an automatic install, it just posts the following error:
Error Partitioning
Could not allocate requested partitions:
requested FileSystemType needs a flag that is not available

Keep in mind that this is saying "remove all Linux partitions" or even
"remove all partitions on the system" options. 20GB disk, FC2 worked
fine, have no idea why this installer borked on the iMac DV (except
that it was a text mode install)

This graphical installer worked fine on several other macs, w/o issue.
I might try to reproduce this with text mode on another box as well.
Comment 1 Jeremy Katz 2004-08-31 11:27:57 EDT
This should be fixed in CVS and rawhide trees as of today (I built a
new anaconda yesterday afternoon)
Comment 2 Colin Charles 2004-09-04 10:59:48 EDT
This is fixed when I manually partition with disk druid, but as of
rawhide from Sep 4th (or is that 3rd your time?), the automatic
partitioning still fails with the same error message
Comment 3 Colin Charles 2004-09-26 05:04:16 EDT
0925 tree, no more such issues, as per comment #2, automatic
partitioning fails, but with the error in bug #121384. So I'm closing
this as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.