Bug 1313875 - Missing: Deploy an overcloud with SSL for the public API
Missing: Deploy an overcloud with SSL for the public API
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-middleware (Show other bugs)
8.0 (Liberty)
x86_64 Linux
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Victor Stinner
Marius Cornea
: Regression
Depends On: 1251257
Blocks: 1298197 1309821
  Show dependency treegraph
 
Reported: 2016-03-02 09:12 EST by Mike Burns
Modified: 2016-04-07 17:32 EDT (History)
41 users (show)

See Also:
Fixed In Version: python-oslo-middleware-2.8.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
With this release, oslo.middleware now supports SSL/TLS, which in turn allows OpenStack services to listen to HTTPS traffic and encrypt exchanges. In previous releases, OpenStack services could only listen to HTTP, and all exchanges were done in cleartext.
Story Points: ---
Clone Of: 1251257
Environment:
Last Closed: 2016-04-07 17:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 231930 None None None 2016-03-02 09:12 EST

  None (edit)
Comment 4 Ronnie Rasouli 2016-03-10 03:42:20 EST
was able to deploy SSL with public API address, the public API address binded with SSL, the  Keystone public API in /usr/share/openstack-puppet/modules/tripleo/manifests/loadbalancer.pp  ${keystone_public_api_vip}:5000" => $haproxy_listen_bind_param

verified on python-oslo-middleware-2.8.0-3.el7ost.noarch
Comment 5 errata-xmlrpc 2016-04-07 17:32:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.