Bug 1315413 - Mouse cursor vanishes in activity overview or when interacting with activity toolbar.
Mouse cursor vanishes in activity overview or when interacting with activity ...
Status: CLOSED DUPLICATE of bug 1316010
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
: 1315590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 11:34 EST by Alex Markley
Modified: 2016-03-10 07:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 07:18:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Markley 2016-03-07 11:34:07 EST
Description of problem:

When logged into gnome-shell under Xorg on a fully-updated Fedora 23 system, the mouse cursor suddenly becomes invisible when entering into the activities overview, or when interacting with the activities toolbar.

Version-Release number of selected component (if applicable):

The problem appears to be caused by the update to mutter-3.18.3-1.fc23

How reproducible:

100% reproducible.

Steps to Reproduce:
1. Log in to gnome-shell.
2. Enter activities overview.
3. Observe mouse cursor has disappeared.

Actual results:

Invisible mouse cursor.

Expected results:

Mouse cursor should remain visible.

Additional info:

I solved this problem for myself by downgrading mutter (dnf downgrade mutter)

This version is running currently without any problems: mutter-3.18.1-4.fc23
Comment 1 lefred 2016-03-07 18:46:09 EST
I confirm, I had the same problem, I could also not see the cursor on the top menubar.

Downgrading mutter also fixed the problem.
Comment 2 Giedrius Slavinskas 2016-03-08 05:07:30 EST
Same here, downgrading mutter solves the issue. It is a critical bug for non-tech users.
Comment 3 Bryan Mason 2016-03-08 14:55:09 EST
This looks like a duplicate of Bug 1315590.
Comment 4 Bryan Mason 2016-03-08 14:58:23 EST
*** Bug 1315590 has been marked as a duplicate of this bug. ***
Comment 5 Bryan Mason 2016-03-08 15:01:09 EST
I'm seeing this on a desktop:

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

and my Lenovo T530:

01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [NVS 5400M] (rev a1)

It was also reported on the following hardware in Bug 131590:

Lenovo M30-70 laptop with i915 graphics (Intel Corporation Haswell-ULT Integrated Graphics Controller).
Comment 6 Juan Orti 2016-03-08 15:20:38 EST
In my PC with a radeon card I don't have this problem.

# rpm -q mutter
mutter-3.18.3-1.fc23.x86_64

# lspci
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Barts XT [Radeon HD 6870]
Comment 7 Alex Markley 2016-03-08 15:26:56 EST
For reference, this is the hardware configuration I am running which is affected by this problem:

$ dmesg | grep -i macbookpro
[    0.000000] DMI: Apple Inc. MacBookPro12,1/Mac-E43C1C25D4880AD6, BIOS MBP121.88Z.0167.B15.1510261437 10/26/2015

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

I am happy to provide any additional information as requested.
Comment 8 Florian Müllner 2016-03-10 07:18:31 EST

*** This bug has been marked as a duplicate of bug 1316010 ***

Note You need to log in before you can comment on or make changes to this bug.