Bug 1315559 - SEEK_HOLE and SEEK_DATA should return EINVAL when protocol support is missing
SEEK_HOLE and SEEK_DATA should return EINVAL when protocol support is missing
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.5.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
Sudhir D
: Triaged
Depends On: 1315557
Blocks: glusterfs-3.5.9
  Show dependency treegraph
 
Reported: 2016-03-07 23:45 EST by Niels de Vos
Modified: 2016-06-17 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1315557
Environment:
Last Closed: 2016-06-17 12:22:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2016-03-07 23:45:21 EST
+++ This bug was initially created as a clone of Bug #1315557 +++

Description of problem:
GlusterFS 3.7 and earlier do not have support for the (new) SEEK FOP. There is no check in glfs_lseek() for unknown SEEK_* operations, this needs to be added

Version-Release number of selected component (if applicable):
3.7 and before

How reproducible:
100%

Steps to Reproduce:
1. call glfs_lseek(..., ..., SEEK_DATA)

Actual results:
No error is returned.

Expected results:
-1 should get returned, and errno should have been set to EINVAL.

Additional info:
Found through code inspection while replying to http://lists.nongnu.org/archive/html/qemu-block/2016-03/msg00119.html
Comment 1 Vijay Bellur 2016-03-07 23:55:46 EST
REVIEW: http://review.gluster.org/13634 (gfapi: return EINVAL for unsupported  lseek() operations) posted (#1) for review on release-3.5 by Niels de Vos (ndevos@redhat.com)
Comment 2 Vijay Bellur 2016-03-08 00:19:57 EST
REVIEW: http://review.gluster.org/13634 (gfapi: return EINVAL for unsupported  lseek() operations) posted (#2) for review on release-3.5 by Niels de Vos (ndevos@redhat.com)
Comment 3 Vijay Bellur 2016-03-09 00:21:36 EST
COMMIT: http://review.gluster.org/13634 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit 206ccaa4f417da633af3860a3ffae896d517fdd0
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Mar 8 05:39:01 2016 +0100

    gfapi: return EINVAL for unsupported  lseek() operations
    
    GlusterFS 3.8 contains support for SEEK_DATA/SEEK_HOLE. This protocol
    extension is not available in 3.5. libgfapi needs to handle unsupported
    SEEK_* operations correctly, by returning -1 and setting errno to
    EINVAL.
    
    This change is different from the patch in the master branch, it is only
    needed to do the improved error checking in this version.
    
    BUG: 1315559
    Change-Id: I142dde11923244809b03fcca8cd4c2f7d5ff3929
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/13634
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 4 Niels de Vos 2016-06-17 12:22:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.9, please open a new bug report.

glusterfs-3.5.9 has been announced on the Gluster mailinglists [1] a while back, and packages for several distributions should be available by now.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.maintainers/486

Note You need to log in before you can comment on or make changes to this bug.