Bug 131607 - Gedit should turn on a couple plugins by default
Gedit should turn on a couple plugins by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 108678 112549 116338 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-02 13:30 EDT by Jonathan Blandford
Modified: 2013-04-02 00:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 16:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Schema patch to enable spelling plugin (640 bytes, patch)
2004-09-15 18:50 EDT, John (J5) Palmieri
no flags Details | Diff

  None (edit)
Description Jonathan Blandford 2004-09-02 13:30:21 EDT
Would be nice to turn on spell checker by default to get rid of the
empty 'Tools' menu item.  Long term, having that menu greyed out or go
away when there are no plugins would be good, but adding a plugin by
default is a nice band-aid.  The spell checker is actually pretty
nice, too.
Comment 1 Bryan W Clark 2004-09-03 12:43:06 EDT
upping priority on this since it's actually really silly to have the
empty tools menu and the spell checker is pretty essential.
Comment 2 Dan Williams 2004-09-07 01:02:45 EDT
Technically we do ship a bunch of plugins, its a problem of getting a
couple of GConf keys into the user's gconf at time of install though,
or at least adding a GConf schema that has a couple plugins listed by
default.
Comment 3 John (J5) Palmieri 2004-09-15 18:50:39 EDT
Created attachment 103887 [details]
Schema patch to enable spelling plugin

Here is the schema patch to enable the spelling plugin by default.  I have
tested and it works once a user logs out and back into their session.  Ok to
commit?
Comment 4 John (J5) Palmieri 2004-09-16 16:17:09 EDT
Built in fc3-hold.
Comment 5 Dan Williams 2004-09-16 16:54:57 EDT
*** Bug 108678 has been marked as a duplicate of this bug. ***
Comment 6 Dan Williams 2004-09-18 13:43:31 EDT
*** Bug 116338 has been marked as a duplicate of this bug. ***
Comment 7 Dan Williams 2004-09-18 13:45:29 EDT
*** Bug 112549 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.