Bug 1316398 - [ja] Japanese Release Notes Desktop file presents same name as for English
[ja] Japanese Release Notes Desktop file presents same name as for English
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Bíba
QE Internationalization Bugs
: Documentation, Translation
Depends On: 1316777
Blocks: 1262678 1340415 1313607
  Show dependency treegraph
 
Reported: 2016-03-10 02:50 EST by Jens Petersen
Modified: 2016-11-04 04:24 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272493
Environment:
Last Closed: 2016-11-04 04:24:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Jens Petersen 2016-03-10 06:15:22 EST
Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP.spec contains:

```
cat > Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP-7.desktop <<'EOF'
[Desktop Entry]
Name=Red_Hat_Enterprise_Linux 7: Release_Notes
Comment=Release Notes for Red Hat Enterprise Linux 7
Exec=xdg-open %{_docdir}/Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP-%{version}/index.html
Icon=Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP
Categories=Documentation;X-Red-Hat-Base;
Type=Application
Encoding=UTF-8
Terminal=false
EOF
```

compared to 

cat > Red_Hat_Enterprise_Linux-Release_Notes-7-en-US-7.desktop <<'EOF'
[Desktop Entry]
Name=Red_Hat_Enterprise_Linux 7: Release_Notes
Comment=Release Notes for Red Hat Enterprise Linux 7
Exec=xdg-open %{_docdir}/Red_Hat_Enterprise_Linux-Release_Notes-7-en-US-%{version}/index.html
Icon=Red_Hat_Enterprise_Linux-Release_Notes-7-en-US
Categories=Documentation;X-Red-Hat-Base;
Type=Application
Encoding=UTF-8
Terminal=false
EOF

ie the Name and Comment for the Japanese RelNotes is identical to the English one which makes it impossible to distinguish them on the desktop.

Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP-7.desktop should be changed to have Name and Comment based on the Japanese title for the release notes.
Comment 3 Noriko Mizumoto 2016-03-10 21:01:34 EST
I had the chat with Lee on this. I learned that this can not be corrected by the author, but this requires some investigation by Publican developer thus needs to file a bug against Publican product. It may take longer...
Comment 4 Radek Bíba 2016-07-18 01:49:06 EDT
This is on track. Will be fixed by manually tweaking the .spec file before building the RPM package so that the .desktop file gets generated with the right content (Red Hat Enterprise Linux 7 リリースノート).
Comment 8 errata-xmlrpc 2016-11-04 04:24:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2544.html

Note You need to log in before you can comment on or make changes to this bug.