Bug 1272493 - [zh_CN, zh_TW] [firefox] Desktop file translations missing.
[zh_CN, zh_TW] [firefox] Desktop file translations missing.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Horak
Engineering Localization bugs mailing list
: Translation
Depends On:
Blocks: 1262678 1313485 1340415
  Show dependency treegraph
 
Reported: 2015-10-16 10:32 EDT by Krishna Babu K
Modified: 2016-08-09 05:40 EDT (History)
12 users (show)

See Also:
Fixed In Version: firefox-45.3.0-1.el7_2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313607 1313620 1316398 (view as bug list)
Environment:
Last Closed: 2016-08-09 05:40:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FAIL Category definition document defined by l10n team lead. (17.08 KB, application/vnd.oasis.opendocument.graphics)
2015-10-16 10:34 EDT, Krishna Babu K
no flags Details

  None (edit)
Description Krishna Babu K 2015-10-16 10:32:47 EDT
Description of problem:

As per translators comments in l10n qa event, translations for this package falls under FAIL-4 and FAIL-1 category - POT is inconsistent with UI

Version-Release number of selected component (if applicable):

gnome-menus-3.13.3-3.el7.x86_64

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:

Translation not used in UI from repository or translations missing

Expected results:

Translations should be available or complete.

Additional info:

FAIL Categories are defined by l10n team lead, and the file is attached with this bug.

Translators comments on TCMS :

locale [zh_TW]

“FAIL-4 POT inconsistent with UI,
Unable to provide translation due to not in file, List of the strings”
Some strings in Applications menu were not localized. 

locale [zh_CN]

Games menu is not shown.
FAIL-4 POT inconsistent with UI, Unable to provide translation due to not in file:
1) Firefox Web Browser
2) Release_Notes
3) Satellite Registration
4) Startup Applications

locale [ko]

FAIL-4 POT inconsistent with UI, Unable to provide translation due to not in file:
Release_Notes
Satellite Registration

locale [pt_BR]

FAIL-4 POT inconsistent with UI,
Unable to provide translation due to not in file, List of the string: Red Hat Access sub-menu is in English.

locale [fr]

IcedTea Web Control Panel is not translated. (Applications>Misc).
Satellite Registration is not translated (Applications>Systen Tools

locale [it]

- System Tools (Strumenti di sistema) -> Satellite Registration (is in English)
- The conte of Nuova finestra (New window) is in English
Fail-1 

locale [es]

FAIL-4 POT inconsistent with UI,
Unable to provide translation due to not in file, List of the strings”
Comment 1 Krishna Babu K 2015-10-16 10:34 EDT
Created attachment 1083713 [details]
FAIL Category definition document defined by l10n team lead.
Comment 3 Noriko Mizumoto 2016-01-14 20:24:43 EST
1) Firefox Web Browser
2) Release_Notes
3) Satellite Registration
4) Startup Applications

There are no such strings in 'master'.
https://l10n.gnome.org/module/gnome-menus/

Could you please point correct repo to get POT/POs to translate?
Comment 4 sandeep shedmake 2016-01-21 10:24:07 EST

(In reply to Noriko Mizumoto from comment #3)

<snip>

> Could you please point correct repo to get POT/POs to translate?


From Comment 3,

branch: * rhel-7.3
Name: gnome-menus
Version: 3.13.3
Release: 3%{?dist}

./gnome-menus-3.0.pot: 0 translated messages, 27 untranslated messages.
 
./de.po: 27 translated messages.
./es.po: 27 translated messages.
./fr.po: 27 translated messages.
./it.po: 27 translated messages.
./ja.po: 27 translated messages.
./ko.po: 27 translated messages.
./pt_BR.po: 27 translated messages.
./ru.po: 27 translated messages.
./zh_CN.po: 27 translated messages.
./zh_TW.po: 27 translated messages.
Comment 5 Noriko Mizumoto 2016-01-21 10:55:32 EST
Hi Matthias

The stat of comment 4 indicates the package localized 100% while there are couple of strings reported as unlocalized in comment 3. I've looked in the upstream, there is no 3-13 version, https://l10n.gnome.org/module/gnome-menus/.

Could you kindly point where to find POT/POs?
(added Jens)
Comment 6 Matthias Clasen 2016-01-21 14:57:19 EST
(In reply to Noriko Mizumoto from comment #3)
> 1) Firefox Web Browser
> 2) Release_Notes
> 3) Satellite Registration
> 4) Startup Applications


These strings come from the desktop files of the individual applications and are shipped in their rpms. For firefox, that is the firefox rpm, for startup applications, that is gnome-session (I think). I have no idea what the package names for the two RH-specific additions are. But you can probably find them by grepping for the string in /usr/share/applications/ and then using rpm -qf on the desktop file.
Comment 7 Noriko Mizumoto 2016-01-27 04:01:00 EST
[RHEL7.3] Assigned to Jens for rhel7.3 localization preparation.
Comment 8 Noriko Mizumoto 2016-01-27 04:03:01 EST
Jens-san, tried to identify the package by following Matthias' instruction.
if these help...

1. firefox-38.2.1-1.el7_1.x86_64
2. Red_Hat_Enterprise_Linux-Release_Notes-7-en-US-7-2.el7.noarch
3. rhn-setup-gnome-2.0.2-6.el7.noarch
4. gnome-session-3.14.0-4.el7.x86_64
Comment 9 Jens Petersen 2016-03-01 21:41:17 EST
We need to clone/open to the other 3 components.
One bug needed per component as usual.
Comment 10 Jens Petersen 2016-03-01 22:19:15 EST
Also I fear one bug is needed per Red_Hat_Enterprise_Linux-Release_Notes-7-*-*.
We should discuss that one with L10n and Docs.
Comment 11 Parag Nemade 2016-03-02 00:42:15 EST
If I look into file /usr/share/applications/firefox.desktop , I see it clearly shows translations available for ko, pt_BR, fr, it and es.

[Desktop Entry]
Version=1.0
Name=Firefox Web Browser
Name[ca]=Navegador web Firefox
Name[cs]=Firefox Webový prohlížeč
Name[es]=Navegador web Firefox
Name[fa]=ﻡﺭﻭﺭگﺭ ﺍیﻦﺗﺮﻨﺗی Firefox
Name[fi]=Firefox-selain
Name[fr]=Navigateur Web Firefox
Name[hu]=Firefox webböngésző
Name[it]=Firefox Browser Web
Name[ja]=Firefox ウェブ・ブラウザ
Name[ko]=Firefox 웹 브라우저
Name[nb]=Firefox Nettleser
Name[nl]=Firefox webbrowser
Name[nn]=Firefox Nettlesar
Name[no]=Firefox Nettleser
Name[pl]=Przeglądarka WWW Firefox
Name[pt]=Firefox Navegador Web
Name[pt_BR]=Navegador Web Firefox
Name[sk]=Internetový prehliadač Firefox
Name[sv]=Webbläsaren Firefox


So only zh_CN and zh_TW translations are missing.
Comment 12 Noriko Mizumoto 2016-03-02 03:06:44 EST
Matthias

I realized now giving translation those four strings cost expensive for us.
First POT/POs has to be extracted from repo and push to Zanata, making all translators to work. This task is repeated 4 times for 4 packages. Second, translators go to the package, find corresponding string and give the translation that string only and leave any other strings untouched. This task is repeated against 4 packages x 10 languages. Third, updated POs are pulled and a patch is created. This task again is repeated 4 times.

Is any other efficient way we can take, such as one file with 4 strings? 
It will save a lot of our time. I am hesitating to proceed the above process, and put this on hold.

* firefox-38.2.1-1.el7_1.x86_64
* Red_Hat_Enterprise_Linux-Release_Notes-7-en-US-7-2.el7.noarch
* rhn-setup-gnome-2.0.2-6.el7.noarch
* gnome-session-3.14.0-4.el7.x86_64

noriko
Comment 17 Martin Stransky 2016-04-04 08:15:23 EDT
Please provide the strings we can add to Firefox desktop file. Or please provide a way how we can get them. Thanks!
Comment 22 Noriko Mizumoto 2016-04-26 20:46:59 EDT
Martin, It seems google-doc works on your side. I will organize the translation resource in early June. Once all languages are completed, I will notify in this bug :-)
Comment 23 Noriko Mizumoto 2016-06-17 03:53:26 EDT
Hi Martin,
All ten languages translation for target string have now been added in the sheet.
Please include them in the package, thanks!
https://docs.google.com/spreadsheets/d/1mgxxULM34dqFJZKaOFTbV3z76r63h0woNv52ev5CIHc/edit#gid=0
Comment 24 Jan Horak 2016-06-17 04:58:36 EDT
Will be fixed by next security update.
Comment 25 Jan Horak 2016-08-09 05:40:38 EDT
Fixed in firefox-45.3.0-1.el7_2.

Note You need to log in before you can comment on or make changes to this bug.