Bug 1313607 - [zh_TW, zh_CN, ko_KR, pt_BR, fr_FR, it_IT, es_ES] rhn-setup-gnome.desktop translations missing.
[zh_TW, zh_CN, ko_KR, pt_BR, fr_FR, it_IT, es_ES] rhn-setup-gnome.desktop tra...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
: Translation
Depends On: 1272374 1313620 1316398
Blocks: 1262678 1340415
  Show dependency treegraph
 
Reported: 2016-03-01 22:05 EST by Jens Petersen
Modified: 2016-11-04 02:21 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272493
Environment:
Last Closed: 2016-11-04 02:21:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Parag Nemade 2016-03-02 00:29:44 EST
The current state of translations for this package is
de.po: 284 translated messages, 26 fuzzy translations, 113 untranslated messages.
es.po: 380 translated messages, 37 fuzzy translations, 6 untranslated messages.
fr.po: 341 translated messages, 31 fuzzy translations, 51 untranslated messages.
it.po: 253 translated messages, 26 fuzzy translations, 144 untranslated messages.
ja.po: 272 translated messages, 26 fuzzy translations, 125 untranslated messages.
ko.po: 253 translated messages, 26 fuzzy translations, 144 untranslated messages.
pt_BR.po: 323 translated messages, 29 fuzzy translations, 71 untranslated messages.
ru.po: 301 translated messages, 27 fuzzy translations, 95 untranslated messages.
zh_CN.po: 323 translated messages, 29 fuzzy translations, 71 untranslated messages.
zh_TW.po: 299 translated messages, 27 fuzzy translations, 97 untranslated messages.

which included untranslated string "Satellite Registration" which is required for this bug fix.
Comment 3 Parag Nemade 2016-03-02 00:32:43 EST
Should this project be imported in zanata, if yes please add me as maintainer there.
Comment 4 Noriko Mizumoto 2016-04-11 00:36:25 EDT
Parag,
https://translate.engineering.redhat.com/project/view/rhn-client-tools/versions
v6.8 100% translated, no such string 'Satellite Registration'. I can't find your username there. Are you rhn-client-tool is for rhn-setup-gnome-2.0.2-6.el7.noarch?
Comment 5 Parag Nemade 2016-04-11 13:05:43 EDT
I have not given the permissions to push the pot in zanata hence you will not find this new string "Satellite Registration" in Zanata. When I created new pot file from existing source I can see untranslated strings. This is the bug for untranslated string "Satellite Registration".
Comment 6 Noriko Mizumoto 2016-04-12 00:46:06 EDT
Now given.
Comment 7 Parag Nemade 2016-04-12 01:00:52 EDT
Thanks Noriko. I have pushed new pot file in Zanata.
Comment 8 Noriko Mizumoto 2016-04-12 03:46:15 EDT
Hi Tomas,

In order to fix this bug ('Satellite Registration' is reused in gnome-menu of RHEL-7.3), only one string translation is required. Besides I can see many of fuzzies and untranslated strings, which workload would be btw 3 to 7 hours per language. rhn-client-tools package is not in Tier1 important list for RHEL-7. 

I don't know if this entire translation update is important and impact to rhel-7.3 or your team is planning to request update later time to suit your development cycle for another product release. Could you kindly give some input on this?
Comment 9 Tomáš Kašpárek 2016-05-27 09:16:07 EDT
Hello,

from comment#0 I don't think this is related with rhn-client-tools and it looks like the issue lies within gnome-menus package. Could you please provide reproducer so we can double check that this issue is not related to rhn-client-tools?

Thanks
Tomas
Comment 10 Parag Nemade 2016-06-16 10:03:46 EDT
Okay let's go through gnome-menus source code again.
1) checkout 7.3 branch of gnome-menus
2) rhpkg prep
3) Generate new pot
3) grep -in "Satellite Registration" gnome-menus-3.13.3/po/gnome-menus-3.0.pot 
===> No results

Now, 
1) checkout 7.3 branch of rhn-client-tools
2) rhpkg prep
3) Generate new pot
4) 
[parag@localhost po]$ grep -in "Satellite Registration" rhn-client-tools.pot 
934:"To learn more about RHN Classic/Red Hat Satellite registration and "
2120:msgid "Satellite Registration"
[parag@localhost po]$ 

This can clearly show that untranslated string "Satellite Registration" is from rhn-client-tools package.

If we look from where this string is coming then check in pot file
======================================
#: ../rhn_register.desktop.in.h:1
msgid "Satellite Registration"
msgstr ""
======================================

Then also if we want to check what desktop file is this then see
$ cat rhn_register.desktop.in 
[Desktop Entry]
Encoding=UTF-8
_Name=Satellite Registration
_GenericName=Register for software updates from Spacewalk/Red Hat Satellite/Red Hat Network Classic
_Comment=Register to Spacewalk/Red Hat Satellite/Red Hat Network Classic.
Exec=rhn_register
Icon=up2date
Terminal=false
Type=Application
Categories=System;Settings;X-Red-Hat-Base;


Can you please now confirm that string is really coming from rhn-client-tools package?
Comment 11 Noriko Mizumoto 2016-06-21 22:41:51 EDT
Hi Tomas

Now nine languages have been 100% completed for rhel-7.3 branch, including targeted string. Could you please repackage with these latest translations?
https://translate.engineering.redhat.com/iteration/view/rhn-client-tools/rhel-7.3.0

I am expecting this translation update to be reflected in Alpha release, so that we can use alpha for l10n QA test. Could you please also give '+' to devel-ack.


Thanks

noriko
Comment 12 Tomáš Kašpárek 2016-07-22 04:56:58 EDT
Package rhn-client-tools-2.0.2-8.el7 which contains updated strings has been built in Brew.
Comment 17 errata-xmlrpc 2016-11-04 02:21:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2427.html

Note You need to log in before you can comment on or make changes to this bug.