Bug 131670 - "Preferred Applications" won't save Mailer preferences
Summary: "Preferred Applications" won't save Mailer preferences
Status: CLOSED DUPLICATE of bug 109738
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 131875 132100 (view as bug list)
Depends On:
Blocks: FC3Target 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-03 00:21 UTC by Zack Cerza
Modified: 2013-04-02 04:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gconftool-2 --dump /desktop/gnome/url-handlers (6.35 KB, text/plain)
2004-09-22 22:11 UTC, Zack Cerza
no flags Details

Description Zack Cerza 2004-09-03 00:21:35 UTC
Description of problem:
gnome-default-applications-properties, all of a sudden, has decided
that Emacs is my preferred text editor, which had been 'Text Editor.'
It won't let me revert the change.

Version-Release number of selected component (if applicable):
control-center-2.7.1-1

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-default-applications-properties
2. Change preferred text editor from Emacs to Text Editor
3. Close gnome-default-applications-properties, saving changes
4. Start gnome-default-applications-properties again
  
Actual results:
Preferred text editor is Emacs

Expected results:
Preferred text editor is Text Editor

Additional info:
Poking around in gconf, I see:
/desktop/gnome/applications/
                            browser/
                            component_viewer/
                            help_viewer/
                            terminal/
                            window_manager/

Shouldn't I see something like 'text_editor/' here? Maybe the setting
is stored elsewhere...

When my i386 box is less wonky I'll see if I can reproduce it there.

Comment 1 Alexander Larsson 2004-09-03 10:29:10 UTC
Text editor changes the mime data, but the code has not been changed
to use the new mime type system.

In fact, it spews g_warning about using deprecated apis.

Comment 2 Zack Cerza 2004-09-03 15:55:15 UTC
I've also realized that my browser and mailer are locked down as well.
Not my terminal, though.

Comment 3 Zack Cerza 2004-09-08 20:05:54 UTC
*** Bug 132100 has been marked as a duplicate of this bug. ***

Comment 4 Zack Cerza 2004-09-08 20:09:32 UTC
Text editor and browser are back to normal. Mailer is still borked.

Comment 5 Dave Malcolm 2004-09-08 20:28:03 UTC
evolution binary is /usr/bin/evolution-2.0 , with a symlink from
/usr/bin/evolution
(not evolution-1.6)

Comment 6 Zack Cerza 2004-09-22 22:11:59 UTC
Created attachment 104149 [details]
gconftool-2 --dump /desktop/gnome/url-handlers

OK, it's either gotten worse or I've just started paying more attention. Things
that are broken now in gconf://desktop/gnome/url-handlers :

about/command (stuck as epiphany)
https/command (stuck as epiphany)
mailto/command (stuck as evolution-1.6)
unknown (stuck as epiphany)

jrb: ping?

Comment 7 Zack Cerza 2004-09-22 22:13:43 UTC
s:unknown:unknown/command:

Comment 8 Zack Cerza 2004-09-24 16:43:03 UTC
*** Bug 131875 has been marked as a duplicate of this bug. ***

Comment 9 Zack Cerza 2004-09-24 16:47:25 UTC

*** This bug has been marked as a duplicate of 109738 ***

Comment 10 Red Hat Bugzilla 2006-02-21 19:05:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.