Bug 1317232 - home overlay thinks ext4 is vfat
home overlay thinks ext4 is vfat
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 04:48 EDT by Todd
Modified: 2016-03-28 11:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-28 11:58:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bash -x (500.28 KB, text/plain)
2016-03-18 20:07 EDT, Todd
no flags Details

  None (edit)
Description Todd 2016-03-13 04:48:41 EDT
Scientific Linux 7.2

# rpm -qa \*livecd\*
livecd-tools-20.1-3.el7.nux.x86_64

# dd bs=4096 if=/dev/zero of=/dev/sdc
# livecd-iso-to-disk --format --reset-mbr --delete-home --home-size-mb 4095 --overlay-size-mb 4095 --unencrypted-home Fedora-Live-Xfce-x86_64-23-10.iso /dev/sdc

Can't have a home overlay greater than 4095MB on VFAT



Checking the actual file type, I get
# fdisk -l /dev/sdc
   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *        2048    31281151    15639552   83  Linux

and gparted says it is ext4

It would be nice to allocate home directories larger than 4095 on ext4 drives
Comment 1 Brian Lane 2016-03-16 18:15:48 EDT
Make sure you have extlinux available, it will fall back to msdos if it isn't available.
Comment 2 Todd 2016-03-18 16:49:32 EDT
It is there.  Reopening.


# which extlinux
/usr/sbin/extlinux


# /usr/sbin/extlinux
Usage: /usr/sbin/extlinux [options] directory
  --install    -i  Install over the current bootsector
  --update     -U  Update a previous installation
  --zipdrive   -z  Force zipdrive geometry (-H 64 -S 32)
  --sectors=#  -S  Force the number of sectors per track
  --heads=#    -H  Force number of heads
  --stupid     -s  Slow, safe and stupid mode
  --raid-mode  -r  Fall back to the next device on boot failure
  --once=...   -o  Execute a command once upon boot
  --clear-once -O  Clear the boot-once command
  --reset-adv      Reset auxilliary data
  --menu-save= -M  Set the label to select as default on the next boot



Bug #1: even with extlinux installed, livecd-iso-to-disk reverts to msdos

Bug #2: extlinux should be in the RPM's dependancies.  

Bug #3: the livecd-iso-to-disk script should give an error message if extlinux is missing.

This is a sub I place in my bash scripts to check dependancies:

CheckDependancy () {
   # $1 = name of dependancy

   Col_Red="\x1b[31;01m"
   Col_Reset="\x1b[39;49;00m"

   if [ -z "$(which "$1" 2> /dev/null)" ]; then
      echo -e "...Unable to locate ${Col_Red}${1}${Col_Reset}"
      echo "   install it with"
      echo "   # yum install $1"
      echo "         -- exiting (bummer dude)"
      Pause
      exit 2
   fi
}


I also have one for Perl5, if you want it.
Comment 3 Brian Lane 2016-03-18 18:19:01 EDT
Can you run it as bash +x livecd-iso-to-disk ... and grab the output and attach it here.
Comment 4 Todd 2016-03-18 20:07 EDT
Created attachment 1137918 [details]
bash -x

 bash -x livecd-iso-to-disk --format --reset-mbr --delete-home --home-size-mb 4095 --overlay-size-mb 4095 --unencrypted-home Fedora-Live-Xfce-x86_64-23-10.iso /dev/sdc  > livetrace.txt 2>&1

Right off the bat, on lines 29656 and 29657

+ cp -fT /home/kvm/livecd-iso-to-disk /media/tgttmp.1uRLQW/LiveOS/livecd-iso-to-disk
cp: cannot stat ‘/home/kvm/livecd-iso-to-disk’: No such file or directory

is a booboo.
Comment 5 Brian Lane 2016-03-21 13:28:46 EDT
Sigh. It wants $0 to point to the script, so instead of running with bash -x add 'set -x' to the top of the script.

Also, it looks like the filesystem is ext4:

+ mkfs=/sbin/mkfs.ext4
+ /sbin/mkfs.ext4 -L LIVE /dev/sdc1
mke2fs 1.42.9 (28-Dec-2013)
Filesystem label=LIVE
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
960992 inodes, 3841280 blocks
192064 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=2151677952
118 block groups
32768 blocks per group, 32768 fragments per group
8144 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208

Allocating group tables:   0/118       done                            
Writing inode tables:   0/118       done                            
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information:   0/118       done

++ /sbin/blkid -s UUID -o value /dev/sdc1
+ TGTLABEL=UUID=648509d4-7e2c-468a-8887-33932570bc20
+ checkFilesystem /dev/sdc1
+ dev=/dev/sdc1
++ /sbin/blkid -s TYPE -o value /dev/sdc1
+ TGTFS=ext4

And as I've said in the other bugs, you're trying to make a f23 iso which may not even work after fixing any bugs.
Comment 6 Todd 2016-03-23 22:16:42 EDT
Hi Brian,

I am not sure what you mean by:  "It wants $0 to point to the script, so instead of running with bash -x add 'set -x' to the top of the script."

I can do this, but it will give you the same result, unless I am missing something.

What would you like me to do?

-T
Comment 7 Todd 2016-03-25 16:57:26 EDT
Hi Brian,

After upgrading livecd-tools, this is no longer an issue.  

See: https://bugzilla.redhat.com/show_bug.cgi?id=1317241

Thank you for look at this for me!

-T
Comment 8 Todd 2016-03-25 17:05:18 EDT
Ooops!  Reopening:

$ rpm -qa livecd-tools
livecd-tools-23.2-3.el7.nux.x86_64

# livecd-iso-to-disk --format --reset-mbr --efi --delete-home --home-size-mb 4095 --overlay-size-mb 8829 --unencrypted-home /home/kvm/Fedora-Live-Xfce-x86_64-23-10.iso /dev/sdc


Waiting for devices to settle...
mkfs.fat 3.0.20 (12 Jun 2013)
Can't have an overlay of 4095 MB or greater on VFAT
Comment 9 Brian Lane 2016-03-28 11:58:36 EDT
You added --efi which means it has to be VFAT, so this is normal.

Note You need to log in before you can comment on or make changes to this bug.