This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1317447 - [RFE] Ability to choose new Mac address from pool when importing VMs from data storage domain.
[RFE] Ability to choose new Mac address from pool when importing VMs from dat...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.6.0
All Linux
high Severity medium (vote)
: ovirt-4.1.0-beta
: 4.1.0.2
Assigned To: Yevgeny Zaspitsky
Meni Yakove
: EasyFix, FutureFeature
: 1399936 (view as bug list)
Depends On:
Blocks: 1226206 1421009 1421425
  Show dependency treegraph
 
Reported: 2016-03-14 05:37 EDT by Yaniv Lavi (Dary)
Modified: 2017-02-28 23:21 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This feature allows you to request a new MAC address when importing a virtual machine from a data storage domain. This allows you to avoid importing a virtual machine with a bad MAC address, which might cause MAC collision in the target LAN. A MAC address would be considered "bad" when it is in use already in the target cluster, or it is out of the range of the MAC pool of the target cluster.
Story Points: ---
Clone Of: 1226206
Environment:
Last Closed: 2017-02-01 09:52:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.1+
rule-engine: exception+
mburman: testing_plan_complete+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 67593 master MERGED webadmin: Add re-assign bad macs column to register VM dialog 2016-12-29 08:22 EST
oVirt gerrit 68034 master MERGED webadmin: add select all header for re-assign bad MACs column 2016-12-29 08:22 EST
oVirt gerrit 68557 master MERGED webadmin: make RegisterEntityModel more type-specific 2016-12-29 08:21 EST
oVirt gerrit 68558 master MERGED webadmin: add type-safety in RegisterVmPopupView 2016-12-29 08:22 EST
oVirt gerrit 69302 ovirt-engine-4.1 MERGED webadmin: make RegisterEntityModel more type-specific 2016-12-29 11:13 EST
oVirt gerrit 69303 ovirt-engine-4.1 MERGED webadmin: add type-safety in RegisterVmPopupView 2016-12-29 11:13 EST
oVirt gerrit 69304 ovirt-engine-4.1 MERGED webadmin: Add re-assign bad macs column to register VM dialog 2016-12-29 11:13 EST
oVirt gerrit 69305 ovirt-engine-4.1 MERGED webadmin: add select all header for re-assign bad MACs column 2016-12-29 11:14 EST

  None (edit)
Description Yaniv Lavi (Dary) 2016-03-14 05:37:04 EDT
We have situations where we need to change a MAC address on a VM following a migration from one environment to another. At present you can only remove the NIC and then recreate with a MAC address from the Pool. What we need is the ability to select a new MAC from the Pool as well.

When importing a storage domain and in the import VMs dialog, we want to have a option to reset mac from pool. This should have a select all option as well. It is not expected anything to be changed within the guest.
Comment 1 Yaniv Lavi (Dary) 2016-11-30 04:18:30 EST
*** Bug 1399936 has been marked as a duplicate of this bug. ***
Comment 3 Michael Burman 2017-01-08 08:46:27 EST
Verified on - 4.1.0-0.4.master.20170105161132.gitf4e2c11.el7.centos

Note You need to log in before you can comment on or make changes to this bug.