Bug 1421425 - [Docs][RFE][Admin] New option to assign new MAC address when importing VMs
Summary: [Docs][RFE][Admin] New option to assign new MAC address when importing VMs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ovirt-4.1.1
: ---
Assignee: Emma Heftman
QA Contact: Tahlia Richardson
URL:
Whiteboard:
: 1421009 (view as bug list)
Depends On: 1226206 1317447
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 08:56 UTC by Emma Heftman
Modified: 2019-05-07 13:15 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-12 08:22:15 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)
MAC in use example (93.65 KB, image/jpeg)
2017-02-23 13:43 UTC, Yevgeny Zaspitsky
no flags Details

Description Emma Heftman 2017-02-12 08:56:59 UTC
Previously, when importing a virtual machine from a data storage domain, if the virtual machine had a “bad” MAC address, a MAC collision may have occurred in the target LAN. A “bad” MAC address  is an address that is already in use or an address that is out of the range in the target cluster. In this release, it is possible to assign a new MAC address when importing the virtual machine from a data storage domain.

See bug https://bugzilla.redhat.com/show_bug.cgi?id=1226206

Update section: https://access.redhat.com/documentation/en/red-hat-virtualization/4.0/single/administration-guide/#sect-Importing_Existing_Storage_Domains

Comment 1 Lucy Bopf 2017-02-16 04:33:25 UTC
Assigning to Emma for review.

Comment 2 Emma Heftman 2017-02-22 13:10:09 UTC
Yvgeny, I have a few question regarding the feature that you developed>

1. Please let me know exactly what appears in the UI if an imported VM uses the same mac address as an existing vm, or an address that is not in the range.

Does an event appear at the bottom of the screen? An icon in the window, a message? this is not clear in the original bug.
A screenshot would be great.

2. Is there a feature page?

3. How does the user enter a new mac address? Again, a screenshot would help.
Thanks

Comment 3 Yevgeny Zaspitsky 2017-02-23 13:43:39 UTC
Created attachment 1256930 [details]
MAC in use example

1. Please find the attached screenshot. You can see there an exclamation mark next to the VM row and the tooltip that describes why the exclamation mark appeared.

2. http://www.ovirt.org/develop/release-management/features/network/import-vm-net-changes

3. A user doesn't enter the MAC address, but request allocation of a new MAC for the "bad" addresses on the VM that is being imported. On the screenshot, you can see the new column "Reassign bad MACs" that is used for that.

Comment 8 Emma Heftman 2017-02-28 16:01:06 UTC
The final draft was approved offline by Yevgeny.

Tahlia, please review this merge request:

https://gitlab.cee.redhat.com/rhci-documentation/docs-Red_Hat_Enterprise_Virtualization/merge_requests/354

Comment 10 Lucy Bopf 2017-03-01 04:18:12 UTC
*** Bug 1421009 has been marked as a duplicate of this bug. ***

Comment 12 Emma Heftman 2017-03-12 08:22:15 UTC
The updated Administration Guide can now be viewed in the customer portal. Section 8.6.5. Importing Virtual Machines from Imported Data Storage Domains.

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1-beta/html-single/administration_guide/#sect-Importing_Existing_Storage_Domains


Note You need to log in before you can comment on or make changes to this bug.