Bug 131813 - gui install hangs trying to start X11
gui install hangs trying to start X11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 131951 132053 (view as bug list)
Depends On:
Blocks: FC3Target 130007
  Show dependency treegraph
 
Reported: 2004-09-05 01:31 EDT by John Reiser
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-10.0.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 23:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-09-05 01:31:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Default graphical install (CD-ROM boot: <Enter>) hangs when the
installer tries to start X11.  The screen becomes totally black except
for the blinking text cursor at top left corner.  There is no response
to PS/2 keyboard, including <Alt>Fn, <Ctrl><Alt>Fn, and
<Ctrl><Alt><Del>; hardware reset is required.

Version-Release number of selected component (if applicable):
FC3-re0903.0-i386

How reproducible:
Didn't try

Steps to Reproduce:
1. Boot from CD-ROM FC3-re0903.0-i386-disc1-ftp
2. Type <Enter> for default graphical install.
3. Accept default language, etc. from text menus.
    

Actual Results:  Hang with blank screen (except blinking text cursor)
upon trying to start X11.

Expected Results:  Graphical welcome and install.

Additional info:

Video card is ATI Rage 128 Pro Ultra.  Monitor is Sony Multiscan 15sf,
which has no DDC, so it looks like Unprobed Monitor.  Monitor handles
1024x768 @75Hz.

Mediacheck said FAIL, _but_ checking by hand with
  cmp /dev/hdc FC3-re0903.0-i386-disc1-ftp
showed that the error was in block 1302152, which is exactly 32768
bytes from the end of the file (1302152 * 512 = 666701824; file is
666734592.)  I believe that the CD-ROM is OK at least through stage2.
Comment 1 John Reiser 2004-09-05 01:32:32 EDT
Text install from same CD-ROM[s] succeeds.
Comment 2 Jens Petersen 2004-09-06 01:12:10 EDT
The same is true for me for nfs installs: reproduced
on two boxes with different video chips.
Comment 3 Lawrence Lim 2004-09-06 04:28:11 EDT
Same problem for me using nfs install.
Comment 4 John Reiser 2004-09-06 11:02:29 EDT
anaconda-10.0.2-0.20040901235037.1.i386.rpm
is the version in FC3-re0903.0-i386-disc3-rtp.iso/Fedora/RPMS .
Comment 5 Bill Nottingham 2004-09-06 23:35:58 EDT
Can you get some error logs from X trying to start off of vt2/3/4? Or
is the system completely hung?
Comment 6 John Reiser 2004-09-06 23:56:23 EDT
The system is completely hung.  There is no repsonse to <Alt>Fn,
<Ctrl><Alt>Fn, <Ctrl><Alt><DEL>, <Ctrl>C, or anything else on the PS/2
keyboard.  The screen is completely black, except for the blinking
text cursor in the upper left corner.

Comment 7 Jeremy Katz 2004-09-07 00:24:19 EDT
Does X work post-install?  Does booting with 'linux nofb' help?
Comment 8 Jens Petersen 2004-09-07 01:34:23 EDT
Yep, X works fine post-install.
Installing with "linux nofb" doesn't make any difference for me.
Comment 9 Jim Cornette 2004-09-07 07:05:23 EDT
I also had a lockup trying to install via the graphics installer. I
was able to install via text.

When attempting the GUI install, X starts to shift the monitor to
graphics mode, but the computer cannot be rebooted or switched to a
virtual terminal. A hard reset is all that can be commited to exit the
lockup state.

X is broken in my case with the post installation. If the vesa driver
is used during installation, this might not come into play for the
i810 driver problem.
Comment 11 John Reiser 2004-09-07 13:01:54 EDT
Re-trying several times to install when boot: <Enter> from physical
CD-ROM on Athlon i686 box, always hangs when anaconda tries to start X11.

<Alt>F1 [default screen with anaconda msgs]: totally black
<Alt>F2 [shell prompt]: totally black
<Alt>F3 ["Running anaconda script ..." and raw DDC probe info]:
totally black
<Alt>F4 ["using algorithm sse1x2"]: totally black
<Alt>F5 always has same contents as <Alt>F1.

where "totally black" means that even the text cursor has disappeared.
 Console was switched just after the "Skip mediacheck" dialog, because
the "hang" leaves the system totally unresponsive to keyboard. 
Pushing the hardware reset button is required to recover.


Comment 12 Jeremy Katz 2004-09-07 13:08:07 EDT
Are the keyboard LEDs flashing at the point of the hang?  Does sysrq
give anything (alt-sysrq-b would reboot if so, it's a quick test).

(Trying on a box here in parallel)
Comment 13 Jeremy Katz 2004-09-07 13:19:26 EDT
Never mind, I see what this is.  The new names of the xorg font
packages made it so there aren't fonts in stage2 which makes things a
bit unhappy. 

Fixed in CVS
Comment 14 Jeremy Katz 2004-09-07 14:20:38 EDT
*** Bug 131951 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2004-09-08 09:45:11 EDT
*** Bug 132053 has been marked as a duplicate of this bug. ***
Comment 16 Jens Petersen 2004-09-08 23:15:19 EDT
Ok, it no longer hangs :)  however now I see a fatal X error:

:
1...2...3...4...5.... X server started successfully.
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
:
:
you may safely reboot your system
Comment 17 Jens Petersen 2004-09-08 23:23:00 EDT
Ok on my other box it is fine, so my comment 16 must be an X issue
with Radeon support I suppose.
Comment 18 Jim Cornette 2004-09-09 20:23:48 EDT
Having and i810 graphics controller, X hung still during an upgrade
attempted via GUI. I tried  ctl-sysreq-r and ctl-sysreq-b but did not
try alt-sysreq-b to escape. (bad memory, user) I did not remember the
breakout command correctly. However, trying to ctl-alt-Fx to any tty
failed to function. I had to hard reset the computer to recover from
the locked X.

Installing via text mode worked fine. X worked without any adjustments
needed. I did have a refresh problem with earlier CVS versions.

Note You need to log in before you can comment on or make changes to this bug.