Bug 131954 - LANG=C not set when querying /usr/sbin/alternatives
LANG=C not set when querying /usr/sbin/alternatives
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cups (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-07 09:02 EDT by Yue Shi Lai
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yue Shi Lai 2004-09-07 09:02:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.54  [en]

Description of problem:
Exactly the same issue as Bug 124217 in Fedora Core.

In

/usr/share/printconf/util/cups_import.py
/usr/share/printconf/util/printconf_conf.py
/usr/share/printconf/util/queueTree.py

it should read

f = os.popen ('LANG=C /usr/sbin/alternatives --display print')

instead of

f = os.popen ('/usr/sbin/alternatives --display print')

as e.g. for German locale, the produced message is

"Link verweist auf..."

rather than

"Link currently points on..."

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.12

How reproducible:
Always

Steps to Reproduce:
1. Issue /etc/init.d/cups restart

or

1. Start redhat-config-printer  

Actual Results:  File "/usr/share/printconf/util/queueTree.py", line 
243, in get_active_spooler    return which
UnboundLocalError: local variable 'which' referenced before 
assignment

(Because which never was assigned, as no "Link currently points on" 
string match occured.)

Expected Results:  No error message should occur.

Additional info:
Comment 1 Tim Waugh 2004-09-07 09:06:53 EDT

*** This bug has been marked as a duplicate of 131563 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.