Bug 13220 - [text-installation] Translated "Welcome" screen title truncated
[text-installation] Translated "Welcome" screen title truncated
Status: CLOSED DUPLICATE of bug 12334
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
: 13221 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-29 14:03 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-01 12:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-06-29 14:03:47 EDT
Noted during a text mode installation using Swedish:

The "welcome to red hat linux" screen has a title in the upper right hand
corner. I think this is the text string displayed:

#: ../iw/welcome_gui.py:11 ../iw/welcome_gui.py:38 ../text.py:911
#: ../text.py:946
msgid "Welcome"
msgstr "Vdlkommen"

The problem is, the translated string gets truncated to "Vdlkomm". The rest
doesn't fit on the screen.
Comment 1 Christian Rose 2000-06-29 18:23:58 EDT
It's not just that title, it's all of the translated titles that are longer than
their originals it seems.
For example, the

#: ../text.py:929 ../text.py:997 ../textw/userauth_text.py:172
msgid "User Account Setup"
msgstr "Konfiguration av anvdndarkonton"

message gets truncated to "Konfiguration av a", the length of the original. This
is really broken - there's no way I can translate that to anything in the same
lenght as the original or shorter in Swedish so that it fits. I noticed this
problem with other languages too.
Comment 2 Michael Fulbright 2000-06-30 16:10:05 EDT
*** Bug 13221 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2000-06-30 16:10:49 EDT
*** Bug 13221 has been marked as a duplicate of this bug. ***
Comment 4 Christian Rose 2000-07-01 12:37:48 EDT

*** This bug has been marked as a duplicate of 12334 ***
Comment 5 Christian Rose 2000-07-01 13:05:17 EDT
Sorry for this. This bug (reported by me) is a duplicate of a previous one, so I
marked it as "DUPLICATE", but that was unfortunately "RESOLVED DUPLICATE". Since
this bug isn't resolved yet (at least I don't think so) the more correct would
be "CLOSED DUPLICATE", so I changed it to that, but forgot to tell why.

Hope this makes the change history for this bug somewhat clearer.

Note You need to log in before you can comment on or make changes to this bug.