Bug 132559 - drop usermount from default desktop install
drop usermount from default desktop install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
: 170811 (view as bug list)
Depends On:
Blocks: 131589 131645
  Show dependency treegraph
 
Reported: 2004-09-14 14:41 EDT by Bryan W Clark
Modified: 2013-07-02 19:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.82-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 16:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch (1.10 KB, patch)
2005-10-25 02:42 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Bryan W Clark 2004-09-14 14:41:28 EDT
GNOME Nautilus handles user mountable drives now, therefore this tool
has become very obsolete.

Lets drop this from the default desktop install
Comment 1 Bill Nottingham 2004-09-14 14:44:41 EDT
Part of usermode-gtk, needed for pam-panel-icon and bits. Can't do that.
Comment 2 Bryan W Clark 2004-09-14 15:07:13 EDT
Ok, lets drop the .desktop file or set NoDisplay=True so that it
doesn't appear in the menus.
Comment 9 Jindrich Novy 2004-09-29 07:00:02 EDT
Bryan,

it is true that Nautilus handles user mountable drives now, but many
people use usermount not only for this purpose. The functionality that
Nautilus (AFAIK) cannot substitute is to format filesystems (for
example a customer uses usermount to do this #117793), where one can
specify which fs should be created in quite user friendly way. This is
the reason why I won't drop usermount from default desktop install.
Comment 10 Bryan W Clark 2004-09-29 12:33:55 EDT
Jindrich,

I was assuming that the floppy formatter would be the best option for
the type of situation in bug 117793 but looking at the code, it
appears the floppy formatter not work on USB floppies.  Apparently
it's hard coded to /dev/fd0  There's already a bug about this:
http://bugzilla.gnome.org/show_bug.cgi?id=150782

Are there cases of customers using this tool for formatting disks
other than floppies?  I imagine this is probably true, however both
tools seem to overlap a lot and the usermount seems so minimal that I
think we should look into improving it beyond what it does now.
Comment 11 Jindrich Novy 2004-09-30 04:47:12 EDT
Hello Bryan,

yes, usermount can be used to format any filesystem that is present in
/etc/fstab and an user has permissions to do this. It can be used not
only for the floppies but also for formating USB flash devices, etc.

I know the interface of usermount is designed for maximal
functionality, not for a good impression. Anyway I think it's a pretty
good idea to combine user friendliness of gfloppy with functionality
of usermode. If we do so in gfloppy, I'll remove usermount from the
default desktop install.

thanks,
Jindrich
Comment 12 Jindrich Novy 2005-10-18 06:57:26 EDT
*** Bug 170811 has been marked as a duplicate of this bug. ***
Comment 13 Matthias Clasen 2005-10-25 02:42:05 EDT
Created attachment 120343 [details]
a patch

Jindrich, the attached patch makes usermount accept an optional argument, so
that it can be called to format a specific device. I propose to

a) Add this patch to usermount
b) Add a "Format" menu item to the context menu of other devices in the
nautilus
   "Computer" window, which calls usermount on that device. (I recently added a

   "Format" menuitem for floppies in there which calls gfloppy)
c) Drop usermount from the menus, maybe do it like I did it for gfloppy, by
   adding an <exclude> element to the .menu file. If done in that way, it still

   appears in the menu editor, and users can easily get it back into the menu
   if they miss it.
Comment 14 Jindrich Novy 2005-10-25 05:22:05 EDT
Matthias, sounds good to me. But I'm not quite sure that "usermount" is a
suitable name for an executable that is intended to be used as a formatter when
called with some arguments. (to call `usermount /dev/cdrom` to format something
looks just weird) Maybe we can create "userformat" by symlinking it to usermount
and usermount will decide from argv[0] whether to mount or format something.

The points a) and b) are fine, good idea. There's a problem with c) that there's
no menu file present is usermode (only desktop ones) so did you mean you want me
to fix it in Nautilus?
Comment 15 Matthias Clasen 2005-10-25 07:15:10 EDT
I think calling 'usermount /dev/cdrom' to format a cdrom is not much wierder than 
calling 'usermount' and selecting /dev/cdrom from the list to do the same task, or
figuring out that the task of formatting a cdrom is hidden beneath "System Tools
>  Disk Management". But if you prefer it, 'userformat' is fine with me.

Regarding c), the relevant menu file is  /etc/xdg/menus/applications.menu in
redhat-menus. I can handle b) and c). Maybe I should file separate bugs to track
them.
Comment 16 Jindrich Novy 2005-10-26 16:16:22 EDT
Ok, userformat is now created. You can use it now for formatting requests.
Closing this bug RAWHIDE now as the point a) is now finished. Please create new
bugs if some further work is needed on the usermode side.

Note You need to log in before you can comment on or make changes to this bug.