Bug 131645 - cleanup system tools menu
Summary: cleanup system tools menu
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Seth Nickell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 131619 132559 133011
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-02 20:08 UTC by Matthias Clasen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 21:14:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Clasen 2004-09-02 20:08:45 UTC
Is it really intentional to have xcdroast in the system tools menu ?
Also it it doesn't use the consolehelper mechanism like the other items
in that menu, but instead brings up a dialog that explains that it has
to be run and configured by root first.

Also, usermount ("Disk Management") seems totally redundant with what
we have elsewhere...

Comment 1 Matthias Clasen 2004-09-02 20:21:02 UTC
Also, xmtr ("Traceroute") seems to be redundant with gnome-nettools,
and should probably not in the menu

Comment 2 Bill Nottingham 2004-09-02 20:46:34 UTC
xcdroast probably shouldn't even be installed by default.

Comment 3 Bryan W Clark 2004-09-03 18:57:44 UTC
Yes, the nautilus CD Creator should deprecate xcdroast.

yes, xmtr ("Traceroute") should be removed since nettools is being
moved to this menu, see bug 131619

yes, usermount ("Disk Management") should be removed.  It is redundant
with nautilus/gnome-vfs share mounting from the My Computer system. 
The only other functionality it provides is floppy formatting which
can be done from the Floppy Formatter :-)

Comment 4 Zack Cerza 2004-09-03 22:06:18 UTC
( xmtr hangs within 3s of startup on x86_64 ... )

Comment 5 Bill Nottingham 2004-09-03 22:08:41 UTC
If xmtr a) doesn't work, and b) is supserceded by gnome-nettools,
should we just stop building it?

Comment 6 Zack Cerza 2004-09-03 22:19:33 UTC
IMO, yes. For reference, the hang-on-start bug is #131754

Comment 7 Bryan W Clark 2004-09-24 20:42:27 UTC
xmtr was dropped in bug 133011

the relevant usermount stuff is being done in bug 132559

notting, I didn't see xcdroast in the latest install.  I'm assuming
you've removed that from the default install?

Comment 8 Bill Nottingham 2004-09-24 21:06:46 UTC
Yes.


Note You need to log in before you can comment on or make changes to this bug.