Bug 1326410 - /var/lib/glusterd/$few-directories not owned by any package, causing it to remain after glusterfs-server is uninstalled
Summary: /var/lib/glusterd/$few-directories not owned by any package, causing it to re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1324820
Blocks: 1326413 1331853 1333900
TreeView+ depends on / blocked
 
Reported: 2016-04-12 15:24 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 14:03 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1324820
: 1326413 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:03:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-12 18:18:42 UTC
REVIEW: http://review.gluster.org/13981 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Vijay Bellur 2016-04-13 18:10:31 UTC
REVIEW: http://review.gluster.org/13981 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Vijay Bellur 2016-04-18 14:31:28 UTC
REVIEW: http://review.gluster.org/13981 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Vijay Bellur 2016-04-26 15:46:43 UTC
COMMIT: http://review.gluster.org/13981 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 1866836749c2a12ae50abd109429da072ebe05ba
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 12 11:35:38 2016 -0400

    packaging: additional dirs and files in /var/lib/glusterd/
    
    Add the missing /var/lib/glusterd files and dirs found by
    downstream testing. Use a loop to create hook dirs instead
    of open-coding. Merge the %ghost and non-ghost dirs in
    -server %files section for easier maintenance.
    
    Eliminate a benign warning for enabling non-existent
    glusterfsd.{init,service} which is only relevant to Fedora
    builds
    
    Don't reject glusterfs.spec.in changes because of long lines
    
    Change-Id: I5802175d729e0168eea879a2a61626b0b73d77c8
    BUG: 1326410
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13981
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 5 Vijay Bellur 2016-05-06 16:09:58 UTC
REVIEW: http://review.gluster.org/14243 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 6 Vijay Bellur 2016-05-06 16:22:53 UTC
REVIEW: http://review.gluster.org/14243 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 7 Vijay Bellur 2016-05-09 09:29:17 UTC
REVIEW: http://review.gluster.org/14243 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)

Comment 8 Vijay Bellur 2016-05-09 11:10:15 UTC
REVIEW: http://review.gluster.org/14243 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)

Comment 9 Vijay Bellur 2016-05-09 12:59:50 UTC
REVIEW: http://review.gluster.org/14243 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 10 Vijay Bellur 2016-05-09 13:46:45 UTC
REVIEW: http://review.gluster.org/14243 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 11 Vijay Bellur 2016-05-09 17:31:40 UTC
COMMIT: http://review.gluster.org/14243 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 731d15a018f3c2451f72c84f4e07aa23c8abc8d2
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Fri May 6 12:07:41 2016 -0400

    packaging: additional dirs and files in /var/lib/glusterd/
    
    Directory /var/lib/glusterd/glusterfind/.keys doesn't need
    to be created, it just needs to be listed in the list of files.
    
    Also, S57glusterfind-delete-post.py under the hooks directory
    is actually a symlink to libexec/glusterfs/glusterfind/...
    so don't list %attr(...) for the symlink
    
    Change-Id: Ia4571a7b5d0cc79c70cc120f7770bf2e6453bc84
    BUG: 1326410
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14243
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 12 Vijay Bellur 2016-05-11 11:28:25 UTC
REVIEW: http://review.gluster.org/14294 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

Comment 13 Vijay Bellur 2016-05-12 09:19:58 UTC
REVIEW: http://review.gluster.org/14294 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

Comment 14 Vijay Bellur 2016-05-13 01:39:05 UTC
COMMIT: http://review.gluster.org/14294 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 803069efb9f5c5d809237543044577f1a71a10d3
Author: Milind Changire <mchangir@redhat.com>
Date:   Wed May 11 16:53:10 2016 +0530

    packaging: additional dirs and files in /var/lib/glusterd/
    
    Add directories /var/lib/glusterd/hooks and /var/lib/glusterd/hooks/1
    to the list for server package ownership
    
    Correct spelling for
    /var/lib/glusterd/ss_brick and
    /var/lib/glusterd/snaps
    
    Change-Id: I5dffa1db610ccd7e1db4082977dd53afec4aecba
    BUG: 1326410
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/14294
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 15 Niels de Vos 2016-06-16 14:03:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.