Bug 1326413 - /var/lib/glusterd/$few-directories not owned by any package, causing it to remain after glusterfs-server is uninstalled
Summary: /var/lib/glusterd/$few-directories not owned by any package, causing it to re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1324820 1326410
Blocks: 1331853 1333900
TreeView+ depends on / blocked
 
Reported: 2016-04-12 15:27 UTC by Kaleb KEITHLEY
Modified: 2016-06-28 12:14 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1326410
: 1331853 1333900 (view as bug list)
Environment:
Last Closed: 2016-06-28 11:42:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-12 18:50:50 UTC
REVIEW: http://review.gluster.org/13982 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Vijay Bellur 2016-04-13 18:11:00 UTC
REVIEW: http://review.gluster.org/13982 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#2) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Vijay Bellur 2016-04-18 14:33:20 UTC
REVIEW: http://review.gluster.org/13982 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#3) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Vijay Bellur 2016-04-26 15:46:58 UTC
COMMIT: http://review.gluster.org/13982 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 8781620900bac22e721d6979b72503737c7ddbc7
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Tue Apr 12 14:48:56 2016 -0400

    packaging: additional dirs and files in /var/lib/glusterd/
    
    Add the missing /var/lib/glusterd files and dirs found by
    downstream testing. Use a loop to create hook dirs instead
    of open-coding. Merge the %ghost and non-ghost dirs in
    -server %files section for easier maintenance.
    
    Eliminate a benign warning for enabling non-existent
    glusterfsd.{init,service} which is only relevant to Fedora
    koji builds
    
    Don't reject glusterfs.spec.in changes because of long lines
    
    Backport of
    > Change-Id: I5802175d729e0168eea879a2a61626b0b73d77c8
    > BUG: 1326410
    > http://review.gluster.org/13981
    
    Change-Id: Ica0f54e63ec01056263a27bbcd4a10e469f67e42
    BUG: 1326413
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13982
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 5 Vijay Bellur 2016-05-06 16:12:41 UTC
REVIEW: http://review.gluster.org/14245 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 6 Vijay Bellur 2016-05-06 16:25:41 UTC
REVIEW: http://review.gluster.org/14245 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#2) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 7 Vijay Bellur 2016-05-09 12:53:26 UTC
REVIEW: http://review.gluster.org/14245 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#3) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 8 Vijay Bellur 2016-05-09 13:49:05 UTC
REVIEW: http://review.gluster.org/14245 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#4) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 9 Vijay Bellur 2016-05-09 21:55:31 UTC
COMMIT: http://review.gluster.org/14245 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit c1fe26b32d2e1fb5bd3c305f70968eacd4a15074
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Fri May 6 12:10:32 2016 -0400

    packaging: additional dirs and files in /var/lib/glusterd/
    
    Directory /var/lib/glusterd/glusterfind/.keys doesn't need
    to be created, it just needs to be listed in the list of files.
    
    Also, S57glusterfind-delete-post.py under the hooks directory
    is actually a symlink to libexec/glusterfs/glusterfind/...
    so don't list %attr(...) for the symlink
    
    Change-Id: Ic8cb68682628af7490e60ae542a2d69ef4a40fd6
    BUG: 1326413
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14245
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 10 Milind Changire 2016-05-13 05:05:27 UTC
Posting follow-up patch.
Need to change this to ASSIGNED to get accepted into gerrit.

Comment 11 Vijay Bellur 2016-05-13 05:06:10 UTC
REVIEW: http://review.gluster.org/14316 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 12 Vijay Bellur 2016-05-13 05:36:24 UTC
REVIEW: http://review.gluster.org/14316 (packaging: additional dirs and files in /var/lib/glusterd/) posted (#2) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 13 Vijay Bellur 2016-05-14 22:43:42 UTC
COMMIT: http://review.gluster.org/14316 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 11bb3c4e81e90cac48c4f083ec144354662927eb
Author: Milind Changire <mchangir@redhat.com>
Date:   Wed May 11 16:53:10 2016 +0530

    packaging: additional dirs and files in /var/lib/glusterd/
    
    Add directories /var/lib/glusterd/hooks and /var/lib/glusterd/hooks/1
    to the list for server package ownership.
    
    Correct spelling for
    /var/lib/glusterd/ss_brick and
    /var/lib/glusterd/snaps
    
    Change-Id: I5dffa1db610ccd7e1db4082977dd53afec4aecba
    BUG: 1326413
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/14294
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    (cherry picked from commit 803069efb9f5c5d809237543044577f1a71a10d3)
    Reviewed-on: http://review.gluster.org/14316
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 14 Kaushal 2016-06-28 12:14:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.