Bug 132804 - Double-clicking an RPM in Nautilus doesn't install the RPM
Summary: Double-clicking an RPM in Nautilus doesn't install the RPM
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
(Show other bugs)
Version: 3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 133760 145502 (view as bug list)
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-17 09:41 UTC by Dee-Ann LeBlanc
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 21:21:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dee-Ann LeBlanc 2004-09-17 09:41:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
When I'm in Nautilus as a regular user, I expect that I should be able
to double-click an RPM, have it ask me for my root password, and have
the RPM install for me. Instead, what happens is that it opens File
Roller and tries to extract the RPM's contents. I don't know if this
is a bug or a feature but it's not very useful for a regular RPM.
Maybe for a SRC RPM as an option, but not a regular one. :)

This is in FC3T3candidate0908

Version-Release number of selected component (if applicable):
nautilus-2.7.92-3

How reproducible:
Always

Steps to Reproduce:
1. Double-click Home icon to open home directory
2. Double-click Desktop icon 
3. Double-click Downloads icon
4. Double-click RPM file
    

Actual Results:  file roller opens the contents of the file, if it can
find any

Expected Results:  the RPM should install (or I should be asked for my
root password and then it should install)

Additional info:

Comment 1 Alexander Larsson 2004-09-17 09:56:43 UTC
This is very strange. I get this too, and system-install-packages
isn't even in the open with menu. But system-install-packages.desktop
is in mimeinfo file, and its even the default in the defaults.list!


Comment 2 Alexander Larsson 2004-09-21 15:48:55 UTC
This is because system-install-packages.desktop has onlyshowin=KDE.

This is not needed anymore. Gnome now supports NoDisplay=true.



Comment 3 Jeremy Katz 2004-09-21 18:01:57 UTC
Fixed in CVS, will be in the next build

Comment 4 Ray Strode [halfline] 2004-09-29 07:21:09 UTC
*** Bug 133760 has been marked as a duplicate of this bug. ***

Comment 5 Bryan W Clark 2004-09-29 21:21:04 UTC
Appears fixed in system-config-packages-1.2.18-1

closing.

Comment 6 Jeremy Katz 2005-01-19 21:04:03 UTC
*** Bug 145502 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.